×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Kunena menu comes and goes. Repeatable

More
3 years 4 months ago #1 by eammendola
Let me preface this by saying that I have searched the forum(s) and I have reviewed the Kunena menu troubleshooting documentation, and have used the suggested methods for resolving Kunena menu related issues.

This is a new Kunena 5.0.6.1 install on a recent Joomla 3.6.5 build.
Other environmental info:
PHP Built On - Linux info 3.0 #1337 SMP Tue Jan 01 00:00:00 CEST 2000 all GNU/Linux
Database Version - 5.5.54-0+deb7u2-log
PHP Version - 7.0.15
Web Server - Apache
Joomla! Version - Joomla! 3.6.5 Stable
Joomla! Platform Version - Joomla Platform 13.1.0 Stable

I have purchased and installed the Powered By Remover.

The forum on my site is only viewable to registered users. Main menu item pointing to Kunena forum is only viewable to registered users.
The Kunena menu appears to be viewable only under certain conditions and disappears under other conditions. The conditions are 100% repeatable.

I tried rebuilding the menu. I tried wiping it out and restoring it. I haven't made any changed to the CSS for the menu. The permissions on the Kunena menu are the "out-of-the-box" settings.

By shear accident I found that I am only able to get the menu links to display by clicking on the dropdown at the far right of the menu (where my avatar shows really small), then clicking on "preferences". As long as I stay within the forum context, the menu seems to remain. However, If I go outside of the forum to any other part of the website and then return to the forum, the Kunena menu items have all disappeared. The outer box border remains, but the button / links are completely gone, until I go back into the little profile dropdown menu, click on preferences and get it to come back.

I have inspected the CSS to see if there is anything changing anything that might effect the display of those items, but I don't see anything.

Please help with resolving this issue. The forum is essentially complete. However, with this issue I can't make it available to our members.

Attached are some screen captures.


Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #2 by rich
Please create a configuration report. www.kunena.org/docs/en/faq/configuration-report

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #3 by eammendola
This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 50000 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : yoo_eat | author: YOOtheme | version: 1.0.8 | creationdate: March 2015

Kunena default template details : Crypsis | author: Kunena Team | version: 5.0.6.1 | creationdate: 2017-01-28

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.0.6.1 | 2017-01-28 [ Falanouc ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #4 by rich
Links of other menus, which are linked to the forum, must be Menu Item Type = Menu Item Alias (see the image) .
There is a wrong menu item in your main menu.
320 Discussion Board mainmenu view=home&defaultmenu=271 member-area/discussion-board

Please Log in or Create an account to join the conversation.

More
3 years 4 months ago #5 by eammendola
This resolved my issue. Thank you for your help.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.519 seconds