×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved Deep link to forum post not possible after upgrade to Kunena 5.5

More
3 years 8 months ago #1 by mibert
Hi there,

after upgrade from Kunena 4 to Kunena 5.5, I found that the deep link to a specific forum post is not possible anymore.
I have already tried many things to solve the issue, but still persist:

1) Disabled SEF for Kunena
2) Deleted all SEF data for Kunena from SEF component
3) Cleaned cache
4) Changed template and can confirm, that its not a template issue
4) Recreated Kunena Menu

However, still the deep link does not word.
When clicking to the post idea, the link brings me to my starting page (i.e. www.mysite.de/index.php#103726 )

Please see below link to reproduce the issue:
This message contains confidential information


Thanks in advance for your advise, how to fix this matter.

Best regards

Michael

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #2 by 810
I will test it tonight
The following user(s) said Thank You: mibert

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #3 by mibert
Hi 810,

did you have a chance to look at this?
Any idea?

Best regards and have a great day

Michael

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #4 by 810
not yet will do it in a few hours.

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #5 by 810
With the default joomla router I get the correct links:

https://localhost/templates/forum/welcome-mat/16-sdcdsc?start=6#40

on on pagination also the correct urls: https://localhost/templates/forum/welcome-mat/16-sdcdsc?limitstart=0 or https://localhost/templates/forum/welcome-mat/16-sdcdsc?start=6

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #6 by mibert
Hi 810,

did you have a look at the link, which I posted?
Unfortunately its not working for me by some reason.

Do you have any idea, what could be the root cause?

Best regards

Michael

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #7 by 810
could you make a screenshot of the kunena setting on the sef component

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #8 by 810
which sef component do you use?

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #9 by mibert
Hi 810,

I have tried to disable SEF completely in my Joomla configuration.
Under this condition, the problem is gone.

But of course, this is not what I want to do on my life site.

Best regards

Michael

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #10 by mibert
I am using Artio JomSEF.

Best regards

Michael

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.248 seconds