×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Solved got "Please login to view the answers" after upgrade to Kunena 5.0.0

More
4 years 1 month ago #1 by baijianpeng
Formerly I was running Kunena 4.0.11 on Joomla 3.6, today I tried to upgrade Kunena to K 5.0 on my testing server. The process of upgrading is smooth, no error reported. But after upgrade finished, when I tried to read the topics on forum, I see following message in every reply post in every topic:

Please login to view the answers


In fact, my forum is open to public before upgrading. Everyone should be able to read ALL posts in a topic without login in.

Why Kunena ask visitor to login to read replies in topics (the first post of each topic is viewable by public)?

Is this a bug? Or did I missed something in configuration?

Thank you.

www.joomlagate.com/

Chinese Joomla Users' Portal

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago - 4 years 1 month ago #2 by rich
hm.. please check in the "Configuration -> (tab) Security" the option "Hide Replies For Guests". It seems that the option is enabled.
Last edit: 4 years 1 month ago by rich.

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago #3 by baijianpeng
You are right! That option was set to "Yes".

But I remember that I had set it to "No" on Kunena 4.0.11. It must be changed during upgrading.

After I switch back to "No", now guests can see replies on topics.

Thank you.

www.joomlagate.com/

Chinese Joomla Users' Portal

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.076 seconds