×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Solved minimal php requirement?

More
4 years 4 months ago - 4 years 4 months ago #1 by ruud
Hi,

not a bug but an observation :)
When trying to install K5.0.B4 on my server I got the message:
Notice
PHP 5.5.9 is not supported. Minimum required version is PHP 5.5.13, but it is highly recommended to use PHP 7.0.4 or later.

On my server I am running Ubuntu Server 14.04.1 which is a LTS version.
I have googled why this still (LTS = 5 years) Ubuntu version is still using an 'old' PHP version.
As it turns out, it doesn't... Al important (security) fixes are backported to this version and although the version number stay on 5.5.9, it is still up-to-par with the security fixes in the new versions.

So although I understand from a developers point of view you do not want to support your component running on a non-supported version of PHP, this version is supported.

Only problems ahead could be functional changes: changes to functions in PHP 5.5.13 that are not in 5.5.9 and are not added by Ubuntu). My guess is that there aren't any > Ubuntu has a big name to uphold in server OS land...

In my opinion the notice should be a 'warning' (that is probably overlayed on every backend kunena screen as is now the 'this is a beta version' stating I am running on a old php version.
It should not be a showstopper when trying to install.

just my two cents :)

sharing = caring
Last edit: 4 years 4 months ago by ruud.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #2 by 810
Replied by 810 on topic minimal php requirement?
You should update to the new Ubuntu Server 16.04 LTS

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #3 by 810
Replied by 810 on topic minimal php requirement?
then you have also PHP7 And HTTPS/2 support

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #4 by ruud
Replied by ruud on topic minimal php requirement?
That needs more testing then testing K5 :)
A lot of services running on that server (IPTV, Web, Ownloud, Sogo, etc.) All highly integrated.
Desktop upgrade to 16.04 is worst ever in my years with Ubuntu... So for my server I wait for some time and 16.04.1 :)

But what do you think about stop making it blocking for installation and make it a 'sticky' warning?

I have no insight in how K4 was adopted by the community but looking at the changes of K5 (dropping legacy template support) I think all bumps / roadblocks / limitations / etc in installation will not help adoption

sharing = caring

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #5 by xillibit
Replied by xillibit on topic minimal php requirement?
I think i will downgrade the minimum requirement to PHP 5.5.9 to people let migrating

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #6 by ruud
Replied by ruud on topic minimal php requirement?
Hi, found this maintained list of major Linux distros and php versions: www.sasaprolic.com/2013/02/list-of-curre...ersion-in-major.html

I myself would prefer the sticky message in the backend stating that current php / mysql / etc. version is 'unsupported'. So keep the requirement, but not make them 'hard'

sharing = caring

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #7 by ruud
Replied by ruud on topic minimal php requirement?
or you could follow the php.net guidelines: php.net/supported-versions.php

make the requirement match the first 2 release numbers instead of three.
So 5.4 is a nogo, 5.5 is a go (until 10 july when this version goes out of support)

It is then up to the user to decide on what .point release (5.5.9, 5.5.35, etc) he will be running on (if he can decide as this is often imposed by the distro or hoster)

sharing = caring

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago - 4 years 4 months ago #8 by xillibit
Replied by xillibit on topic minimal php requirement?
We can't do that because some versions of Php contains issues in some cases like before 7.0.4

I don't provide support by PM, because this can be useful for someone else.
Last edit: 4 years 4 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #9 by ruud
Replied by ruud on topic minimal php requirement?
okay, agree. See also the discussion on php 7.0.6 that seems 'bugged' :(

sharing = caring

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.153 seconds