×
Blue Eagle 5 v1.5.3 has been Released (31 Mar 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.3 which is now available for download. This version addresses most of the issues that were discovered in development.

Solved Attachment filenames long include server path

More
4 years 2 days ago - 4 years 2 days ago #1 by iaendo
For the past several months I've experienced an unwanted change in the names of file attachments. Here they are:

1: When a file is attached to a forum post, the name automatically changes. When the file is downloaded, the becomes incredibly long. The name is changed from the original filename to one that contains the whole file/directory path on the server. Is there a way to change it back so when a file is downloaded, it retains its original filename?











2: After attaching a file to a forum post, the name displayed is unusually short. The frontend with display only 3-4 characters (other than file extension) rather than the whole filename. How can this be reverted back to prior versions where the entire filename is displayed?




Any help resolving these issues would be greatly appreciated.



This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : beez5 | author: Angie Radtke | version: 2.5.0 | creationdate: 21 May 2010

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.10 | creationdate: 2016-02-18

Kunena version detailed: Kunena 4.0.10 | 2016-02-18 [ Villavicencio ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.0.14+build.2016.04.09.00.43.57.e3fcc2af5 | UddeIM 3.7

Third-party SEF components: None

Plugins: Search - Kunena Search 3.1.2 | Content - Kunena Discuss 3.1.2

Modules: Kunena Latest 3.1.2.1 | Kunena Stats 3.1.2 | Kunena Login 3.1.2 | Kunena Search 3.1.2

Attachments:
Last edit: 4 years 2 days ago by iaendo. Reason: image didnt attach

Please Log in or Create an account to join the conversation.

More
4 years 2 days ago - 4 years 2 days ago #2 by sozzled
I cannot comment on point 1. I haven't seen that issue.

On point 2, this is a defect in K 4.0 (it started around the time of K 4.0.3) and it seems to affect Blue Eagle templates. My guess is that this particular problem will not be fixed (for Blue Eagle templates). There's more to the story here: long file Names .

The issue does not occur to the same extent if you use Crypsis.

Hope that helps a little.
Last edit: 4 years 2 days ago by sozzled.

Please Log in or Create an account to join the conversation.

More
3 years 11 months ago #3 by ssh

iaendo wrote: Is there a way to change it back so when a file is downloaded, it retains its original filename?

If you are using Blue Eagle, you need to turn off Protect Attachments feature.
Joomla backend -> Kunena forum -> Configuration -> Uploads -> Protect Attachments

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #4 by ssh
This has been solved in K.5.xx
@Global_Moderators
Solved+Archive

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.555 seconds