Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Solved [Resolved] Notice: Trying to get property of non-object in / Fatal error: Call to a member function get() on null in

More
8 years 5 months ago #1 by lux
Hello to all. B)

After upgrade Kunena 4.0.8 I encountered these errors:


Notice: Trying to get property of non-object in /****/********/***/components/com_kunena/views/topics/view.html.php on line 358


Fatal error: Call to a member function get() on null in /****/*******/***/components/com_kunena/views/topics/view.html.php on line 359


(***= I moderated sensitive data)


This error occurs for me when a user tried to register on my website. (blank page and the errors mentioned above)


I found the solution on the forum here.
The quickest way to fix the error is to uninstall and re-install Kunena.


When I did this all began to run.



Unfortunately, the problem recurred.


I made many tests and I noticed that if I disable the plugin "plg_system_kunena_v4.0.8" users can register, but of course the forum is not seen, it is offline.


I tried uninstalling the plugin and install it again but the problem remained.


I did other tests and I finally figured out what (in my case) the problem.

The problem is the module "Kunena - Discuss Plugin".


If I install the module "Kunena - Discuss Plugins", no problem.

But if on the module and position it, then that's the problem returns.

So I solved simply by turning off the module "Kunena - Discuss Plugin".

I decided to uninstall module for added security.


I hope that this topic will be of help to others, and that can save you all hours of work I had to do today, to understand what the problem was.

A hug, Luke. ;)

PS: sorry for my bad English. :laugh: :laugh:
The following user(s) said Thank You: xillibit, zomblaa

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #2 by zomblaa
Hi there
I have exactly the same problem, I followed your method, unfortunately it does not solve the problem.
Thank you anyway

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #3 by 810
discuss is a plugin. You can't use it for modules.

Or do you use kunena latest module.

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #4 by 810
The following user(s) said Thank You: zomblaa

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #5 by lux
ok, everything works perfectly.

Kunena great you are the best !! :-)

I love you guys !

Please Log in or Create an account to join the conversation.

Time to create page: 0.437 seconds