Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Important JomSocial - Kunena Integration thanking someone in a forum post

4 years 6 months ago #1 by couchgw
ISSUE SUMMARY: Posts populating in our JomSocial home view indicating that a user thanked another user in a forum topic (USER-A thanked USER-B in topic Policy and Procedures) the hyperlinks to the profile of USER-A and USER-B are non-search engine friendly URLs. The link to the forum topic works fine only the links to the users profiles are not search engine friendly. We have our site set to use search engine friendly URLs so when the link is clicked we are getting the profile opening with other modules vs simply opening the profile as it would with the search engine friendly URLs.

1 Set your joomla site to use search friendly URL's
2 Enable the Kunena - JomSocial Integration
3 Thank someone in a forum post in Kunena
4 View the post in JomSocial

Please Log in or Create an account to join the conversation.

4 years 5 months ago #2 by severdia
I have the same problem. All the JomSocial activity stream updates from Kunena are OK except Thank yous have all the wrong URLs. This is the HTML that's produced:
<div class="joms-stream__meta">
	<a href="\&quot;\index.php?option=com_community&amp;view=profile&amp;userid=29506\&quot;\">Alan Weyman</a> thanked <a href="\&quot;\index.php?option=com_community&amp;view=profile&amp;userid=62\&quot;\">William Shakespeare</a> in topic <a href="\&quot;\https://www.playshakespeare.com/forum/acting/6556-judi-dench-s-10-rules-of-advice-for-performing-shakespeare/6556\&quot;\">Judi Dench's 10 Rules of Advice for Performing Shakespeare</a>      
	<span class="joms-stream__time">
		<small>8 hours 14 minutes ago </small>

Attached are screenshots of the MySQL table and the above code in the activity stream.

Author of Using Joomla from O'Reilly Media. | www.usingjoomlabook.com

Please Log in or Create an account to join the conversation.

4 years 5 months ago - 4 years 5 months ago #3 by 810
Ok found the issue:

Create a language override:
PLG_KUNENA_COMMUNITY_ACTIVITY_THANKYOU_WALL="<a href="_QQ_"%s"_QQ_">%s</a> thanked <a href="_QQ_"%s"_QQ_">%s</a> in topic <a href="_QQ_"%s"_QQ_">%s</a>"

I will change the language file.

Ps Works only on new wall activity's, else you need to edit it on the database.
Last edit: 4 years 5 months ago by 810.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.121 seconds