Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Question User's real name being displayed despite setting in configuration

More
1 month 3 days ago #1 by crimle
I would like to report a suspected bug.

Go to Back-End > Kunena Forum > Configuration > Tab «Users»
Set «Display User Name» to «Yes» (Set to Yes if you want usernames to be displayed instead of real names.)

Go to Front-End > open any thread
Click «Action» then «Reply»
Type «@» followed by any letter
The matching usernames are being displayed followed by the users' real names. I do not think that this is the intention of the setting «Display User Name» = «Yes» mentioned above.

Thank you and kind regards
Chris

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #2 by Gindi
Unfortunately, I cannot reproduce this error.
If I proceed as described and enter "@" followed by any letter, no matching usernames are displayed.

gindi
 

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #3 by crimle
Can it be that the uddeIM Plugin is responsible for this feature?

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #4 by Pinkeltje
Easy to test by disabling UddeIM plugin. My experience is the same as Gindi's. No matches.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #5 by crimle
I disabled any component, plugin and module that contains «uddeim». But I can still type «@» followed by at least 1 character and then the userlist is being displayed. So I guess it must be a Kunena feature that can be enabled or disabled. There are so many options in «Kunena Forum > Configuration» I was not able to find the corresponding setting.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #6 by Pinkeltje
I suppose you can't reproduce it on this forum? Do you have any other Kunena plugins enabled (CB, Jomsocial, Easysocial)?

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #7 by xillibit
Hello,

This is a feature introduced in K6.3 it works only with CKeditor. Here on kunena.org it doesn't work, i will look to fix the issue and change to follow the configuration for username in the list

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #8 by Pinkeltje

Here on kunena.org it doesn't work

Doesn't work on my sites either. Testsite Joomla 5.1, Kunena 6.3.1 fresh install, CKEditor. Testsite Joomla 4.4.4, Kunena 6.3.1, copy from existing forum.

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #9 by Gindi
It does not work on my website and on my test versions with Joomla 5.1 and Kunena 6.3.0 or 6.3.1.
Maybe it only works on new installations.

gindi
 

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #10 by xillibit
Hello,

I had made a fix for that in the K6.3.2 developpement branch : github.com/Kunena/Kunena-Forum/commit/cc...16d0ab20d9a752307ed7

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.492 seconds