Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Question protected category shows 500 error

More
1 month 5 days ago - 1 month 5 days ago #1 by derekk
I made a new top level category
Access Control Type:User Groups
Set primary user group to Registered

When a registered user is given an URL to the new forum and goes to the site and is not logged in they get a 500 error
These are the urls i am using to track users in my next campaign that receive the 500 error


This is the only restricted forum category I have.
Kunena debug does not show anything when turned on

All these URLs return this 500 error I pasted in private tab
  1. Forums
500 Internal Server Error :You may not be able to visit this page because of:
  1. an out-of-date bookmark/favourite
  2. a search engine that has an out-of-date listing for this site
  3. a mistyped address
  4. you have no access to this page
  5. The requested resource was not found.
  6. An error has occurred while processing your request.
If difficulties persist, please contact the website administrator and report the error below.

I assume the 500 error is triggered because of the number 4 reason "you have no access to this page"

However when you are logged in there is no error and you correctly can see and use the forum

Expected behaviour: non logged user is shown the login form with message to login
Actual behaviour: non logged user is shown the 500 error which is unexpected behaviour

I placed sign in info in private message tab

Please review and thank you for your time?

 
Last edit: 1 month 5 days ago by derekk. Reason: remove urls from public view

Please Log in or Create an account to join the conversation.

More
1 month 4 days ago #2 by Pinkeltje
Can confirm. Browsertab also shows 500 error. Can narrow it down partially to layouts/widget/error/default.php.

Please Log in or Create an account to join the conversation.

More
1 month 4 days ago - 1 month 2 days ago #3 by derekk
Edit:
This is the path to the error file  you provided
/public_html/components/com_kunena/template/aurelia/layouts/widget/error/default.php

This is just the error page it does not show errors
Why do you think this file has an error or indicates error?
This file and the error message it shows does not appear to be correct.
There is no 500 error the message shouldnt show up?
It only happens if I change permissions in Kunena to a forum category  to be for registered users
After I log in the category shows fine.

Is there error logs for kunena ?

This kunena error shows in my sites error log
[Mon Apr 22 07:54:03.709302 2024] [security2:error] [pid 25901:tid 22618004457216] [client 99.241.160.21:64755] [client 99.241.160.21] ModSecurity: Warning. Match of "rx ^$" against "FILES_TMPNAMES:install_package" required. [file "/etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/014_i360_filescan.conf"] [line "43"] [id "77317957"] [msg "IM360 WAF: Track file upload||MV:/tmp/20240422-075402-ZiZ6Cuv4cvURPJokldKwGwAAAFU-file-3UhsuD||Size:0||User:asbnca||SC:/home/asbnca/staging.asbn.ca/administrator/index.php||WPU:||T:APACHE||"] [severity "NOTICE"] [tag "service_im360"] [tag "noshow"] [hostname " www.staging.asbn.ca "] [uri "/administrator/index.php"] [unique_id "ZiZ6Cuv4cvURPJokldKwGwAAAFU"], referer: www.staging.asbn.ca/administrator/index....mplate&layout=addnew         Latest suEXEC event log messages:No recent suEXEC events exist for your domain: asbn.ca

Thank you for taking a look .would you mind answering these questions?

Where did you find that did you turn on system debug or Kunena debug
You think this file has an error in it or the file itself layouts/widget/error/default.php does not belong?
Is this a Kunena error if it is perhaps an upgrade or reinstall of kunena might work?

Thank you
Last edit: 1 month 2 days ago by derekk. Reason: Update information

Please Log in or Create an account to join the conversation.

More
1 month 4 days ago #4 by Pinkeltje
I think it is a Kunena issue. You could add it to Github so developers can check.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago - 1 month 2 days ago #5 by derekk
EDIT:
This setting under security tab title "Registered Users Only" Set to Yes to limit all forum access to registered users (view and post).
Set to No to allow any Guest (non registered visitor) to at least see the forum. See 'Allow Guests to post/write' for additional Guest access control.

If I set to "no" then there is no 500 error for logged in or out going to forum both receive correct login message
If logged out go to protected category directly from link they get correct message without 500 error message.
If logged in go to protected category directly from link they get access to protected category correctly without 500 error message.
This is now working as expected

The problem remaining is that if If logged out go to forum or any category, whether the category is protected or not, they get the following
Please Log In
Only community members can participate in this forum. You must register or log in to contribute
.

I want the main forum home page to be viewable by logged out showing to the public logged out viewers all the categories
and showing any category I set and want to be viewed by logged out
In other words I want Kunena to work correctly and show the categories I want to show to logged out and not shoow categories I have protected and do not want to show to   logged out with the correct message to log in to view.

If I set this to "yes" then the 500 error incorrectly shows to logged out visitors.
Please advise on how to correct this?

Dont know if this is related but I also get this system error message now?
Please check your Joomla menus: Default Menu Item in Entry Page is not pointing to Kunena.


















here is my configuration report
Please read my edited reply above as well?


This message contains confidential information

Database collation check: gic_guru_kunena_courseslinkage have wrong collation of type utf8_general_ci on field coursename gic_guru_kunena_lessonslinkage have wrong collation of type utf8_general_ci on field lessonname

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 768M | Max file upload:

Kunena menu details:

Warning: Spoiler!

Joomla default template details : t4_blank | author: JoomlArt | version: 1.1.4 | creationdate: January 14, 2022

Kunena default template details : Aurelia | author: Kunena Team | version: 6.2.0 | creationdate: 2023-10-17

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.2.0 | 2023-10-17 [ Git Repository ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.8.2

Third-party SEF components: None

Plugins: Content - Kunena Discuss 6.0.2-DEV

Modules: Kunena Latest 6.0.2 | Kunena Search 5.2.2

Last edit: 1 month 2 days ago by derekk.

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #6 by rich
If someone accesses a restricted area but is not authorised to do so, this error message is correct: "You do not have access to this page".
If you have a restricted area, make sure that no menu item or link leading to it is visible to users who are not logged in. These menu items should only be visible to registered users.
For guests, you can then create your own menu items leading to the registration form, which will disappear once they are logged in.

As for your menu errors, please read this: As for your menu errors, please read this: Menu Issues

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago - 3 weeks 4 days ago #7 by Pinkeltje
@rich:that should be the case. But it is not. Check \components\com_kunena\template\aurelia\layouts\widget\error\default.php, it shows a not found error. Title showst 401: Unauthorized, this should be 403 and content shows text like indicated before.
Last edit: 3 weeks 4 days ago by Pinkeltje.
The following user(s) said Thank You: SmithDigital

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #8 by derekk
You said "That should be the case. But it is not."
Please clarify, what should be the case?

"Check \components\com_kunena\template\aurelia\layouts\widget\error\default.php,...."
I went to that URL with my domain in front of it and that page is blank it shows no error
I also opened the file itself default.php and it looks fine to me
So I am not sure what you want me to do or where to replicate the error you found?
I also noted the permissions on that file default.php are 0644 is that correct?

" it shows a not found error." I dont see this or know how to find it?

Title is correct 401: Unauthorized, but content is not.
I dont see this or know how to find it?

Please elaborate for me?

Thank you for your help

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #9 by Pinkeltje
derekk, I answered rich. This is an error in Kunena template file.

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #10 by derekk
So I need to fix the default.php file or replace it?
What is the fix or replacement Pinkeltje?

Please Log in or Create an account to join the conversation.

Time to create page: 0.658 seconds