Kunena 6.3.0 released

The Kunena team has announce the arrival of Kunena 6.3.0 [K 6.3.0] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 and issues discovered during the last development stages of K 6.3

Question Error Messages after J3 to J4 upgrade

More
3 weeks 5 days ago #1 by AlexRag
I followed the steps outlined in the docs (in J3 uninstall Kunena, plugins and in J4 install Kunena 6.25, plug in, etc.

I am seeing these error messages:

1. Front End (Any Kunena Menu)
0 Cannot use object of type stdClass as array

2. Backend (Template page) - Aurelia is the only one visible to choose from.
The Joomla\Http\Transport\Stream transport is not supported in this environment.

Any ideas where I should be looking to figure this out?

I am using a Gantry 5 template (Rocketheme) if that helps.  Advise if more info is needed.

Thanks in advance.

Please Log in or Create an account to join the conversation.

More
3 weeks 5 days ago - 3 weeks 3 days ago #2 by AlexRag
I was able to resolve the backend admin error message. My web host enabled "allow_url_fopen".

The first still appears on the front end. Debug mode indicates the following:

Rendering Error in layout Widget/Announcement: Cannot use object of type stdClass as array in /home/.../components/com_kunena/template/aurelia/layouts/widget/announcement/default.php on line 27
Layout was rendered in /home/.../libraries/kunena/src/Html/KunenaParser.php on line 140

AND

Rendering Error in layout Announcement/Listing/Row: Cannot use object of type stdClass as array in /home/.../components/com_kunena/template/aurelia/layouts/announcement/listing/row/default.php on line 35
Layout was rendered in /home/.../components/com_kunena/template/aurelia/layouts/announcement/listing/default.php on line 111

I cannot access the Report configuration settings and getting this error:  "An error has occurred: Object of class stdClass could not be converted to string"

Any idea what the error might mean?

 
Last edit: 3 weeks 3 days ago by xillibit. Reason: Duplicate topic, content of other topic copied here in the message

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #3 by xillibit
Hello,

Did-you right checked to set Aurelia as default ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #4 by AlexRag
Yes in fact that is the only template available when I installed Kunena

Please Log in or Create an account to join the conversation.

More
3 weeks 4 days ago #5 by xillibit
After to have installed Kunena 6.2.x, did-you go to the Kunena dashboard ? And did-you see the messages that the tables of Kunena has been updated ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 weeks 3 days ago - 3 weeks 3 days ago #6 by AlexRag
I don't recall. Should install/reinstall to try again and see if I get that message?  [UPDATE - I reinstalled and saw this error message when I accessed the dashboard

 
Last edit: 3 weeks 3 days ago by AlexRag.

Please Log in or Create an account to join the conversation.

More
3 weeks 3 days ago #7 by xillibit
So now you Kuena tables are updated. There should be an extra upgrade step with the update message to 6.2.4-DEV so the error message could coming for this last step. This last step converting columns of tables in utf8mb4 for which ones which aren't in this format.

Your previous errors have disapeared now ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 weeks 2 days ago #8 by AlexRag
I'm unsure which error you mean, besides the one shown above.

When I reinstalled Kunena the above error continues to appear. I also can't get to the "Report Configuration" settings

And on the front end, I still see this error message:

"0 Cannot use object of type stdClass as array"

I suspect this has something to do with the table conversion you mentioned. If it's failing is there a way to manually process that column conversion?

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #9 by Leen
Hello ,
Have you ever set the server tab to maxium in the Joomla Global Configuration Error Reporting?
Perhaps the cause of your error message will then surface
maybe it's another plugin or extension that's bothering you
And do you sometimes have a link to the website?

L.v.d.A

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #10 by AlexRag
I had the debug set to maximum and saw some errors from the theme (Gantry 5 / Rocketheme) and I have reached out to them to see if this is an issue.

That said, I did switch templates but still see the same error on the front end (see screenshot)

 

I also saw that the SQL version is 5.744, but according to your docs, the minimum needs to be 5.78.   Could this be the problem with that last table not converting?

"0 Cannot use object of type stdClass as array"

 

Please Log in or Create an account to join the conversation.

Time to create page: 0.791 seconds