Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Question Bug: Move message into other category

More
1 month 6 days ago #1 by Ratman
I think I've found a new bug. I try to move a message into a thread of an other category. So I push the "Moderate" button in this message and hit the "Move options" tab. Now when I choose an other "target category", the "Target Topic" scroll-down menu still shows the topics from the old category. So I have to move the topic with a temporary name to the new category first and then I have to moderate again to attach this message to teh right topic.

The same happens when I try to move a whole topic to another category. I tried the same with a copy of my forum which still runs under K5.2.14. As soon as I choose another category, the "Target Topic" dropdown menü shows the topuics in this category.

Hope I decsribed this good enough :)

Please Log in or Create an account to join the conversation.

More
1 month 4 days ago #2 by rich
I cannot reproduce this error. When I select a different category, the corresponding topics are displayed immediately. What happens if you wait a while after selecting another category before selecting the target topics?

Please Log in or Create an account to join the conversation.

More
1 month 4 days ago - 1 month 4 days ago #3 by Pinkeltje
It works for me as well as long as I perform the action in the same section.
 
Last edit: 1 month 4 days ago by Pinkeltje.

Please Log in or Create an account to join the conversation.

More
1 month 4 days ago #4 by Ratman

I cannot reproduce this error. When I select a different category, the corresponding topics are displayed immediately. What happens if you wait a while after selecting another category before selecting the target topics?
I tested this yesterday, changed the category and waited for ~ 3 minutes. But the topic list did not change :(

It works for me as well as long as I perform the action in the same section.
I tested this too. I have three main sections in my forum with severe categories in each section. But even if I choose a categoriy in the same section the topic list does not change.

As I wrote above: I have created a copy of my site before I did the big upgrade of Joomla (from J3 to J5) and Kunena (from K5 to K6). The copy still works fine, as soon as I choose a new category (inside the same section or from a different section), the list of topics changes immediately. But now with all updates installed it does not work anymore.

I also tested with the default templates for the site and Kunena, but this also did not change anything.

This message contains confidential information

Database collation check: The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload:  

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ja_purity_iv | author: JoomlArt | version: 1.2.0 | creationdate: October 31th, 2023

Kunena default template details : NTS KBee | author: Nice Theme Store Team | version: 6.0.1 | creationdate: 2023-12-10

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.2.3 | 2024-01-11 [ Git Repository ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.9.1+build.2024.01.11.19.38.24.c604a3042

Third-party SEF components: None

Plugins: None

Modules: Kunena Search 6.0.5

Please Log in or Create an account to join the conversation.

More
1 month 3 days ago #5 by Pinkeltje
Tested again and I think it is related to the number of topics in a category. For me it only works with categories with less than appr. 10 topics.

Please Log in or Create an account to join the conversation.

More
1 month 3 days ago #6 by rich
Hmm... When I try to merge a post from this topic here with a topic in another category, I see the complete topic list of the target category. Even if the target category is in a different section. I have no idea why this is not the case for you.

Please Log in or Create an account to join the conversation.

More
1 month 3 days ago #7 by Ratman

Tested again and I think it is related to the number of topics in a category. For me it only works with categories with less than appr. 10 topics.
 
I can't confirm this for my forum. Even if the target category has only one topic, I cannot see this in the target.

But thanks anyway for your effort. I can live with this, I'll use my workaround then (copy as a new entry to the target category and then merge/rename)

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago - 1 month 1 day ago #8 by Pinkeltje
I really think this is a bug. I can sometimes move to categories that have a few topics. Tested on a clean site with all default settings and only imported users and Kunena tables.
Last edit: 1 month 1 day ago by Pinkeltje.
The following user(s) said Thank You: Ratman

Please Log in or Create an account to join the conversation.

Time to create page: 0.373 seconds