Kunena 6.2.4 Released

The Kunena team has announce the arrival of Kunena 6.2.4 [K 6.2.4] which is now available for download as a native Joomla extension for J! 4.3.x/4.4.x/5.0.x. This version addresses most of the issues that were discovered in K 6.1 / K 6.2 and issues discovered during the last development stages of K 6.2

Question How to bootstrap K6 in external script

More
1 year 1 month ago #1 by achartier
In previous versions of Kunena I was able to access Kunena classes by including the file JPATH_LIBRARIES.'/kunena/bootstrap.php' this file no longer exists in K6.

I have tried including the JPATH_ROOT . '/administrator/components/com_kunena/api/api.php'  file and I get an error on missing Kunena classes. I tried booting the application, and I tried including the autoloader: JPATH_LIBRARIES . '/kunena/External/autoload.php'

Nothing seems to work. Attempting to use any of the KunenaForum classes fail. I do have all of the use statements included.

My external script is extending the Joomla\CMS\Application\WebApplication and other J! related calls are working fine.

Any help would be greatly appreciated. Thank you.

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #2 by achartier
I was able to get my script to run by creating an autoloader function for the Kunena libraries, but there should be a standard way to bootstrap Kunena for library access.

Please Log in or Create an account to join the conversation.

Time to create page: 0.318 seconds