Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

Question Call to a member function get() on string

More
1 year 3 weeks ago - 1 year 3 weeks ago #1 by aftertaf
I have the same problem, on a clean install of J4.0.5 and Community Builder.
0 Call to a member function get() on string
Call stack : (for when I try to create a new Topic)
# Function Location
1 () JROOT/plugins/kunena/comprofiler/:75
2 KunenaActivityComprofiler->onBeforePost() JROOT/libraries/kunena/src/Integration/:97
3 Kunena\Forum\Libraries\Integration\KunenaActivity->__call() JROOT/components/com_kunena/src/Controllers/:791
4 Kunena\Forum\Site\Controllers\TopicController->post() JROOT/libraries/kunena/src/Controller/:349
5 Kunena\Forum\Libraries\Controller\KunenaController->executeTask() JROOT/libraries/kunena/src/Controller/:240
6 Kunena\Forum\Libraries\Controller\KunenaController->execute() JROOT/components/com_kunena/src/Dispatcher/:113
7 Kunena\Forum\Site\Dispatcher\Dispatcher->dispatch() JROOT/libraries/src/Component/:389
8 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/:206
9 Joomla\CMS\Application\SiteApplication->dispatch() JROOT/libraries/src/Application/:245
10 Joomla\CMS\Application\SiteApplication->doExecute() JROOT/libraries/src/Application/:278
11 Joomla\CMS\Application\CMSApplication->execute() JROOT/includes/:63
12 require_once() JROOT/:32

and
404 Affichage introuvable [name, type, prefix] : topic, html, site
Call stack : when I try to open the 'sample data' post that is created when I pressed the install Sample Data
# Function Location
1 () JROOT/libraries/src/MVC/Controller/:898
2 Joomla\CMS\MVC\Controller\BaseController->getView() JROOT/libraries/kunena/src/Controller/:430
3 Kunena\Forum\Libraries\Controller\KunenaController->display() JROOT/libraries/kunena/src/Controller/:349
4 Kunena\Forum\Libraries\Controller\KunenaController->executeTask() JROOT/libraries/kunena/src/Controller/:240
5 Kunena\Forum\Libraries\Controller\KunenaController->execute() JROOT/components/com_kunena/src/Dispatcher/:113
6 Kunena\Forum\Site\Dispatcher\Dispatcher->dispatch() JROOT/libraries/src/Component/:389
7 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/:206
8 Joomla\CMS\Application\SiteApplication->dispatch() JROOT/libraries/src/Application/:245
9 Joomla\CMS\Application\SiteApplication->doExecute() JROOT/libraries/src/Application/:278
10 Joomla\CMS\Application\CMSApplication->execute() JROOT/includes/:63
11 require_once() JROOT/:32
PHP 8.0.14
MySQLi 10.5.12-MariaDB-0+deb11u1
Last edit: 1 year 3 weeks ago by xillibit.

Please Log in or Create an account to join the conversation.

More
1 year 3 weeks ago #2 by xillibit
Hello,

I have splited it from the original message : www.kunena.org/forum/k-6-0-support/16402...-page-can-t-be-found

Are-you using the beta 6 or a nightly build ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
1 year 2 weeks ago #3 by xillibit
Hello,

Please re-try with beta 7 of kunena 6.0

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.268 seconds