Kunena Released

The Kunena team has announce the arrival of Kunena [K] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

Question After install of Nightly 01-11

1 year 2 months ago - 1 year 2 months ago #1 by cursulak
Everything was going well, I updated to the nightly build of 1-11 and then things broke. My menus become unresponsive - redirecting back to index.php. So I did the trash-burn-rebuild three times! cause each time didn't work. After doing it three times I still didn't see any change. I also notice clicking on the dashboard to come up for Kunena takes for-ever! I mean several minutes. I also noticed that the 'sample data' extension was turned back on. So I turned it off again. Interestingly even when the dashboard does come back up, there it is again, still there to install sample data. It's like it's not ready any changes or saving them yet if I go check out the extension, it is unpublished. Very strange. But here's the stranger thing. So I removed the kunena extensions by uninstall and went back to nightly 01-08. It's still the same now. so going back doesn't fix the problem I have now. I thought I'd post here before I go into the server and manually remove the component directory and reinstall. I also don't want to do a full uninstall as I need the categories and content built up to this point. But it seems like a really simple redirect issue, I just don't understand why a menu rebuild is not fixing it. Here's the config output.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 1000 seconds | Max execution memory: 500M | Max file upload:

Kunena menu details:

Warning: Spoiler!

Joomla default template details : itl_recycling | author: poetsofcode.com | version: 2.1 | creationdate: August 2019

Kunena default template details : Aurelia | author: Kunena Team | version: 6.0.0-BETA7-DEV | creationdate: 2022-01-11

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 6.0.0-BETA7-DEV-GIT | 2022-01-11 [ Git Repository ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.6.4+build.2022.

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 1 year 2 months ago by xillibit.

Please Log in or Create an account to join the conversation.

1 year 2 months ago #2 by xillibit

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

1 year 2 months ago #3 by cursulak
I have done this already specifically all the way back to full release of beta 6. However did this again. It does not appear to change anything, which is leading me to think perhaps something has been written to one of the tables which is causing the error. Using the tools, diagnostics shows no errors. What I did.
Went to system extensions and uninstalled the Kunena extensions.
In the web directory made sure both directories in /components and /administrator/components are removed.
Tried to load from my menu item and get 404 error. (this is the funny part as it knows it's missing).
Reloaded with 01-05 nightly
(repeat all of above with reload of 01-07 nightly. )
trash and burn menu items and rebuild.
No change.

This leads me to believe it's not the web directory files where the problem is, it's in the tables.
I pulled the text from _kunena_configuration below. Could you advise if you see anything that shouldn't be there?

{"boardTitle":"McKLPOA Community","email":"","boardOffline":"0","offlineMessage":"The Forum is currently offline for maintenance.\r\nCheck back soon!","enableRss":"1","threadsPerPage":"15","messagesPerPage":"15","messagesPerPageSearch":"15","showHistory":"1","historyLimit":"6","showNew":"1","disableEmoticons":0,"template":"aurelia","showAnnouncement":"1","avatarOnCategory":"0","showChildCatIcon":"0","rteWidth":450,"rteHeight":300,"enableForumJump":"1","reportMsg":"1","username":"1","askEmail":"0","showEmail":"0","showUserStats":"1","showKarma":"0","userEdit":"1","userEditTime":"0","userEditTimeGrace":"600","editMarkup":"1","allowSubscriptions":"1","subscriptionsChecked":"1","allowFavorites":"1","maxSig":"300","regOnly":"1","pubWrite":"1","floodProtection":"0","mailModerators":"0","mailAdministrators":"0","captcha":"0","mailFull":"1","allowAvatarUpload":"1","allowAvatarGallery":"1","avatarQuality":"75","avatarSize":"2048","imageHeight":"800","imageWidth":"800","imageSize":"30000","fileTypes":"pdf,txt,rtf,zip,tar.gz,tgz,tar.bz2","fileSize":"300000","showRanking":"1","rankImages":"1","userlistRows":"30","userlistOnline":"1","userlistAvatar":"1","userlistPosts":"1","userlistKarma":"0","userlistEmail":"0","userlistJoinDate":"0","userlistLastVisitDate":"1","userlistUserHits":"1","latestCategory":"0","showStats":"0","showWhoIsOnline":"0","showGenStats":"0","showPopUserStats":"0","popUserCount":"5","showPopSubjectStats":"1","popSubjectCount":"5","showSpoilerTag":1,"showVideoTag":1,"showEbayTag":1,"trimLongUrls":"1","trimLongUrlsFront":"40","trimLongUrlsBack":"20","autoEmbedYoutube":"1","autoEmbedEbay":"1","ebayLanguageCode":"en-us","sessionTimeOut":"1800","highlightCode":"0","rssType":"topic","rssTimeLimit":"month","rssLimit":"100","rssIncludedCategories":"","rssExcludedCategories":"","rssSpecification":"rss2.0","rssAllowHtml":"1","rssAuthorFormat":"name","rssAuthorInTitle":"1","rssWordCount":"0","rssOldTitles":"1","rssCache":"900","defaultPage":"recent","defaultSort":"desc","sef":"1","showImgForGuest":"1","showFileForGuest":"1","pollNbOptions":"4","pollAllowVoteOne":"1","pollEnabled":"1","popPollsCount":"5","showPopPollStats":"0","pollTimeBtVotes":"00:15:00","pollNbVotesByUser":"100","pollResultsUserslist":"1","allowUserEditPoll":0,"maxPersonalText":50,"orderingSystem":"replyid","postDateFormat":"ago","postDateFormatHover":"datetime","hideIp":"1","imageTypes":"jpg,jpeg,gif,png","checkMimeTypes":"1","imageMimeTypes":"image\/jpeg,image\/jpg,image\/gif,image\/png","imageQuality":"50","thumbHeight":"32","thumbWidth":"32","hideUserProfileInfo":"put_empty","boxGhostMessage":"0","userDeleteMessage":"1","latestCategoryIn":"1","topicIcons":"1","debug":"0","catsAutoSubscribed":0,"showBannedReason":"0","showThankYou":"1","showPopThankYouStats":"0","popThanksCount":"5","modSeeDeleted":"0","bbcodeImgSecure":"text","listCatShowModerators":"0","lightbox":"1","showListTime":"720","showSessionType":"2","showSessionStartTime":"1800","userlistAllowed":"1","userlistCountUsers":"0","enableThreadedLayouts":0,"categorySubscriptions":"post","topicSubscriptions":"every","pubProfile":"1","thankYouMax":"10","emailRecipientCount":"0","emailRecipientPrivacy":"bcc","emailVisibleAddress":"","captchaPostLimit":"0","imageUpload":"registered","fileUpload":"everybody","topicLayout":"indented","timeToCreatePage":"1","showImgFilesManageProfile":"1","holdNewUsersPosts":"0","holdGuestPosts":"0","attachmentLimit":"8","pickupCategory":"0","articleDisplay":"link","sendEmails":"1","fallbackEnglish":"1","cache":"1","cacheTime":"60","ebayAffiliateId":"5337089937","ipTracking":"1","rssFeedBurnerUrl":"","autoLink":"1","accessComponent":"1","statsLinkAllowed":"1","superAdminUserlist":"0","attachmentProtection":"0","categoryIcons":1,"avatarCrop":"0","userReport":"1","searchTime":"365","teaser":"0","ebayLanguage":"0","ebayApiKey":"","ebayCertId":"","twitterConsumerKey":"","twitterConsumerSecret":"","allowChangeSubject":"1","maxLinks":"6","readOnly":"0","ratingEnabled":"1","urlSubjectTopic":"0","logModeration":"0","attachStart":"0","attachEnd":"20","googleMapApiKey":"","attachmentUtf8":"1","autoEmbedSoundcloud":"1","emailHeader":"media\/kunena\/email\/hero-wide.png","userStatus":"0","signature":"1","personal":"1","social":"1","plainEmail":"0","moderatorPermDelete":"1","avatarTypes":"gif, jpeg, jpg, png","smartLinking":"0","defaultAvatar":"nophoto.png","defaultAvatarSmall":"s_nophoto.png","stopForumSpamKey":"","quickReply":"1","avatarEdit":"0","activeMenuItem":"","mainMenuId":"","homeId":"","indexId":"","moderatorsId":"","topicListId":"","miscId":"","profileId":"","searchId":"","custom_id":"","avatarType":"1","sefRedirect":"1","allowEditPoll":"1","useSystemEmails":"0","autoEmbedInstagram":"1","disableRe":"0","email_sender_name":"","display_filename_attachment":"1","new_users_prevent_post_url_images":"0","minimal_user_posts_add_url_image":"10","utmSource":"0","plugins":[],"emailHeadersizey":560,"emailHeadersizex":560,"moderator_id":null,"profiler":"0","pickup_category":null,"legacyUrls":"0"}

Please Log in or Create an account to join the conversation.

1 year 2 months ago #4 by cursulak
I'm still uncertain how this mess came to be, but it appears to be I cannot create a menu item to get to the forums that doesn't end up in a loop or redirect of some kind not taking me there. 
I've rebuilt the entire menu ID's, blown away the Kuena menu (and any references to it), emptied the trash, rebuilt from scratch and exactly the same problem. Even mentioned earlier the issue of backing out 01-11 install and going right back to beta 6 before nightly didn't change it now. Something is permanently affected. 

Any help would be greatly appreciated as it has permanently knocked out my forums. I know I'm playing with beta software, but it was working so well up till this point for over a month. 

Thanks, hoping to fix this soon. 

Please Log in or Create an account to join the conversation.

1 year 2 months ago #5 by cursulak
I wanted to follow up on this so that those who build the code may want to check if this means anything. 
Since I have the ability to use a couple servers, I started a completely new environment on another server. I backup my site both manually (directory copy and phpmyadmin) as well use Akeeba inside Joomla (for the other admins.). 
In the new environment I actually went to php 8.1 (current was 8.0), anyhow I took an older backup of the directory structure, but a current backup of the database. 
Put it on the new machine environment. This directory structure was of the nightly build 01-08.
The menu problem was not present and everything is functioning normally. I have not and probably won't install any nightly for a while now until a stable b07 is released. 

It could be there was something else buried somewhere causing the problem, however DB structure is exact match, site file structure was put back in time. In looking through the history, there were two changes in that window. Kunena update I did, and SPpagebuilder had a small update. So, I held Kunena at the 01-08 and only updated sppagebuilder. The issue still has not returned. Basically my site is current to the other (old site) with the exceptions of PHP is now 8.1 and Kunena is an older nightly. 

Perhaps look carefully at the 01-11 build? If I have the time I'll try and go back to the older server and see if the update path previously will reproduce the problem but that could be some time in the future. Anyhow, hope this helps at all or at least closes this issue. 

Please Log in or Create an account to join the conversation.

1 year 2 months ago #6 by xillibit

Thanks for the follow up, i have already checked the changes made on K6.0 since begining of january for now i don't found what is causing this isuse

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.266 seconds