Kunena 6.3.3 released

The Kunena team has announce the arrival of Kunena 6.3.3 [K 6.3.3] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Question Slow posts and replys when subscriptions are enabled

More
10 months 2 weeks ago #1 by ianrispin
On my site it takes 15 to 60 seconds to post a new topic or reply.

Rest of site (just browsing) is fast enough.

Have discovered that if, in Kunena config, I set  "Allow subscriptions" to No then the problem goes away and submitting a new post or reply takes just a second or two.

Site has 500k topics, 200k users. Joomla 3.10.12, Kunena 5.2.14

I found and old thread on same topic but its very old:
www.kunena.org/forum/139-K-15-Support-Ar...-subscriptions#25695

Is this a know issue? And ideas on the cause - as the last message in above old post says - it seems that when you click submit to post a topic you then get left hanging in the browser for 30 seconds while some subscription emailing processing is going on in the background - and only after its all done does the user see the page refresh to show their posted topic was submitted OK.

Please Log in or Create an account to join the conversation.

More
10 months 2 weeks ago #2 by ianrispin
After more testing I have further narrowed down the issue.

The option that really slows my site down is "Category Subscriptions" - rather than individual post subscriptions.

I have now enabled subscriptions to posts but disabled subscriptions to categories.

Posting in case this is causing performance problems for other Kunena users.

Fix:
In Kunena config > Users tab >
Set Category Subscriptions to Disabled

The speed of posting and replying on my site has improved from 10 to 60 seconds before to 1 to 2 seconds now.
The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

More
10 months 2 weeks ago #3 by xillibit
Hello,

We had noticed the issue here too on kunena.org, i need to look to find a fix for it

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.502 seconds