Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Question Getting strange errors on Kunena

More
1 year 10 months ago - 1 year 10 months ago #1 by billh210
I have run the diagnostics and cleaned the database but still getting errors, is there a way to export the messages and do a clean install?
What would cause this all of the sudden It has been working fine.
.ErrorDuplicate entry '0' for key 'PRIMARY

'ErrorException throw at line 668 in file /home/basctx/public_html/libraries/joomla/database/driver/mysqli.php with message You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 'test')' at line 3

Now just got a new error

ErrorException throw at line 668 in file /home/basctx/public_html/libraries/joomla/database/driver/mysqli.php with message You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 'I have expired the memberships early to prep the new site for registrations.\r' at line 3
Last edit: 1 year 10 months ago by billh210.

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #2 by Leen
Is the joomla and kunena version and extensions and plug-ins completely up to date?.
And has something else been changed, eg a different PHP version has been set?

L.v.d.A

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #3 by billh210
Updated to the latest Kunena and running Joomla 3.10, just changed the php to 8.0

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #4 by Leen
was the problem not there with your previous php version ?

L.v.d.A

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #5 by billh210
Yes it was there, I updated to PHP 8 thinking that would fix it.

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #6 by rich
You can try following:
Important! First create a backup of your database!
Then download and install the extension Admin Tools . You just have to select UTF-8 Multibyte under "Change Database Collation" (it is already preset) and run it. After that (as recommended) click on "Repair & Optimise Tables".
 

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago #7 by billh210
Tried that still getting an error
Error
Duplicate entry '0' for key 'PRIMARY'

Please Log in or Create an account to join the conversation.

More
1 year 10 months ago - 1 year 10 months ago #8 by Leen
Is the Error Reporting set to maximum in the Joomla site as well?
latest joomla version is 3.10.10. And sometimes also helps with Extensions: Update Sites right at number to everything and then check the box on the left to select everything and then click rebuild. after that click on update extensions clear cache and on new search to make sure everything is up to date
the problem with the website is that with a hoster or is it at a local server like Wamp or Xampp.
And do you sometimes use extra extensions or plug-ins such as JCH optimizer.
sometimes it can help if you also include your Report Configuration 
www.kunena.org/docs/en/manual/backend/to...report-configuration

L.v.d.A
Attachments:
Last edit: 1 year 10 months ago by Leen.

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #9 by Avihaa
Wow, I had the opposite experience. None of my sites would upgrade through Joomla. I have spent the last 3 months rebuilding dozens of client sites from scratch in Joomla 4. The biggest issue is the mandatory images directory. I used a custom user data folder for all of my sites, and the mandatory image directory basically broke all of my websites. Also my third party extensions didn't all come up at the same time so the automatic updates never worked for me.

Please Log in or Create an account to join the conversation.

Time to create page: 0.551 seconds