×
Kunena 5.2.8 released and Blue eagle 1.6.7 released (02 Jan 2022)

The Kunena team has announce the arrival of Kunena 5.2.8 [K 5.2.8] which is now available for download as a native Joomla extension for J! 3.10/3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

If you are using blue template you need to update to 1.6.7 version to ensure to have a compatible version with K5.2.8.

Important note: (07 Jan 2022) If you have created a Kunena custom.css, create a backup of it. Due to an error, this file will be deleted during an upgrade.

Question Guests adding image attachment: You do not have permissions to access this page

More
8 months 2 weeks ago #1 by brentwilliams
Kunena 5.2.6
Blue Eagle 1.6.6
Joomla! 3.10.0
Happens in both BBcode editor and CKeditor

When guests use the attachment feature to add an image, they get this error:  You do not have permissions to access this page.  (Shown above the post as red text)  Then, when an admin views the moderated post, it also shows the "You do not have permissions to access this page" error, although this time within the post, even after the post is approved.  

I dug into the database and the post is made, and the file is on the server, however, what I realized was that in the table, “XXX_kunena_attachments”, there is nothing in the mesid field.  (just shows a “0”).  When I add the topic id in that field, then the image shows properly.

Any ideas?


 

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #2 by rich
It has nothing to do with guest messages. This error happens if users use the browser back and forwards button when they have already added an attachment. Kunena recognize this as abort and the image get no message ID and so it will not be displayed.

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #3 by brentwilliams
Thanks, Rich.  That may happen, as well, but is not what is happening in this instance.  I just went back and tested a clean process of starting a topic, adding a picture, and submitting, all without hitting back.  Unfortunately, the same issue happens, and only with guests.

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #4 by rich
Ok, I was able to reproduce the problem. It occurs when Moderate Guests is enabled. I've added a ticket to our bug list.
github.com/Kunena/Kunena-Forum/issues/8386

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #5 by brentwilliams

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.068 seconds