Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

Solved Error with the Crypsis template: "Rendering Error in layout Widget/Editor"

More
2 years 4 months ago #1 by dankup
Some topics in my Kunena forum items gives follwing error:
"Rendering Error in layout Widget/Editor: Call to a member function get() on null. Please enable debug mode for more information."
And some Kunena itmes and buttons  are displayed out of my Joomla template.

I use the latest Joomla version: 3.10.4, with the default template: protostar.
Kumena version: 5.2.7

Does other Kunena users have  the same problem?
Thanks for advising,
Kind Regards,
Danny.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #2 by dankup
I just did some testing with the basic configuration settings and found that setting "Enable Debug Mode" to "Yes" solved my problem.
Anyone else with the same experience.
What are the disadvantages of setting the debug mode to Yes?

Thanks,
Danny.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #3 by rich
Debug mode is used for debugging and affects the speed. Debug mode uses the uncompressed scripts and CSS files, and normal mode uses the minimized files. Maybe a compressed file is broken, and it helps if you install Kunena over it again.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #4 by dankup
Thanks for the tip. Is it possible to reinstall Kunena and keep the existing topics and discussions?

Kind Regards,
Danny.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #5 by rich
You don't need uninstall Kunena.
If you install Kunena over it, it keeps all topics and discussions, but a backup should always be made beforehand as a matter of principle.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago #6 by dankup
Hi Rich, sorry for my response but I out for a few days.
I was about to reinstall Kunena and I saw on my Joomla Control Panel that there was an update for Kunena: 5.2.7 ==> 5.2.8.
After the update, the error message has disappeared.
I assume running the update can have a similar effect to a reinstall.
Thanks for your advice and happy new year!!!
Regards,
Daniel.

Please Log in or Create an account to join the conversation.

More
2 years 4 months ago - 2 years 4 months ago #7 by rich

I assume running the update can have a similar effect to a reinstall.

Yes, you're right, it's the same.
I also wish you a happy new year!
Last edit: 2 years 4 months ago by rich.

Please Log in or Create an account to join the conversation.

Time to create page: 0.477 seconds