×
Kunena 6.0.6 & Kunena 5.2.13 & blue eagle5 1.6.8 released as security release (28 Nov 2022)

The Kunena team has announce the arrival of Kunena 6.0.6 [K 6.0.6] which is now available for download as a native Joomla extension for J! 4.2.x. This is a security release.

Solved User full name fix when quoting does not work for existing posts

More
11 months 3 weeks ago #1 by btc
HI,

I've installed 5.2.7 on a new copy of my website for testing purposes (the production database is still on 5.1). When testing the quote function, the full name of the user who has been quoted is shown correctly, which wasn't so with 5.2.6.. However, existing posts that have quotes still show only the first name. This happens using both Blue Eagle 5 and Crypsis.

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
       

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 2147483648 | Max file upload: 256M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : business_pro | author: Shape5.com | version: 1.0 | creationdate: August 2013

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.6.6 | creationdate: 2021-07-25

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.7 | 2021-12-04 [ Morella ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.6.4

Third-party SEF components: None

Plugins: Search - Kunena Search 5.2.2 | Content - Kunena Discuss 5.2.2

Modules: Kunena Latest 5.2.2 | Kunena Search 5.1.2

The following user(s) said Thank You: xillibit

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #2 by xillibit
Hello,

Thanks for the report i will take a look

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #3 by rich
Maybe it helps, if you recount the statistics (Dashboard -> Tools)..

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #4 by btc
Thanks for the suggestion, which I tried but didn't work.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #5 by btc
I've just noticed another issue with quotes. The hyperlink just goes to the website root when the a post has been quoted after conversion to K5.2.7. Quotes that were done previously, ie when K5.1 was still used, have only the first name but do have the full path to the post that's been quoted.

Please Log in or Create an account to join the conversation.

More
11 months 1 week ago #6 by xillibit
On Kunena 5.1.19 which Kunena template are-you using ? And which editor type (BBcode or wysibb) do-you have ?

I tried to do couple of quotes on Kunena 5.1.19 then updated to Kunena 5.2.7, but i don't see your issue :

I don't provide support by PM, because this can be useful for someone else.
Attachments:

Please Log in or Create an account to join the conversation.

More
11 months 1 week ago - 11 months 1 week ago #7 by btc
PLEASE CLICK ON SOURCE VIEW BEFORE READING THIS POST!

Thanks for looking into this. I'll try to clarify the situation, which is a bit confusing.

The live website has K5.1.9 and Blue Eagle, but with some overrides in layout/user. All posts have been created using bbCode.

To test K5.2.7 I created a copy of the website using Akeeba in a subdirectory of the live website.

I then installed K5.2.7 and the new version of Blue Eagle on the test website. I removed the layout/user overrides to ensure that they weren't affecting anything.

I then examined earlier posts that included quotes, made on the live website, to see how they showed up using K5.2.7. What I found was that
a) only the first name was shown
b) the name was hyperlinked correctly to the post that was quoted

I then added new posts that quoted from earlier posts and found that:
a) Both names were shown
b) The link was wrong - it was just the root url for the domain, www.pgweb.uk instead of for example www.pgweb.uk/pgcdev4/forums/forums-index...ne-ltn?start=40#6293

Examining the bbcode, I found that the pre-K5.2.7 posts with quotes used the syntax

Adrian Day wrote: , while posts with quotes done on K5.2.7 used a different syntax

Editing these later posts to use the syntax

John Phillips wrote: resulted in the correct link being generated but only the first name shown.

Both Blue Eagle 5 and Crypsis behaved in the same way.

Confusing! I'm sure this would have been noticed if it was happening to everyone, so perhaps it's another example of Kunena behaving strangely on my website, eg the unresolved issue of why it won't send emails to people subscribed to a topic, only to the moderators.

Last edit: 11 months 1 week ago by btc.

Please Log in or Create an account to join the conversation.

More
11 months 1 week ago #8 by btc
Sorry, my last post came out differently than intended because the examples were parsed!

Thanks for looking into this. I'll try to clarify the situation, which is a bit confusing.

The live website has K5.1.9 and Blue Eagle, but with some overrides in layout/user. All posts have been created using bbCode.

To test K5.2.7 I created a copy of the website using Akeeba in a subdirectory of the live website.

I then installed K5.2.7 and the new version of Blue Eagle on the test website. I removed the layout/user overrides to ensure that they weren't affecting anything.

I then examined earlier posts that included quotes, made on the live website, to see how they showed up using K5.2.7. What I found was that
a) only the first name was shown
b) the name was hyperlinked correctly to the post that was quoted

I then added new posts that quoted from earlier posts and found that:
a) Both names were shown
b) The link was wrong - it was just the root url for the domain, www.pgweb.uk instead of for example www.pgweb.uk/pgcdev4/forums/forums-index...ne-ltn?start=40#6293

Examining the bbcode, I found that the pre-K5.2.7 posts with quotes used the syntax where only the username was surrounded by quotation marks, while in the K5.2.7. quotes the entire sequence of username, userid and postid was enclosed in quotation marks. Editing the source for the K5.2.7 posts so that only usernames were in quotation marks generated the correct links but showed only the user's first name.

 

Please Log in or Create an account to join the conversation.

More
11 months 1 week ago - 11 months 1 week ago #9 by xillibit
Hello,

In K5.2.x we have changed something in the bbcode quote tag :

[*quote="Firstname Lastname post=73 userid=394"]text text text[/quote*]

In K5.1 it was like that :

[*quote="Firstname Lastname" post=55"]text text text[/quote*]

I don't provide support by PM, because this can be useful for someone else.
Last edit: 11 months 1 week ago by xillibit.

Please Log in or Create an account to join the conversation.

More
11 months 1 week ago #10 by xillibit
I have made a fix to support bbcode tag done in K5.1 and first versions of K5.2 like it was and to fix the issue with link to post : github.com/Kunena/Kunena-Forum/commit/6b...6f7ba6e3d767c0f38f02

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.340 seconds