Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Solved Can't make public users to be able to post comments

More
2 years 7 months ago #1 by impression
Hi, 

I know this is an old problem, but I couldn't find a solution.
I want to allow everyone to post, but I can't see the "New Topic" button when not logged in.

In the "configuration > security" I have set "Allow Guests to Post/Write"=Yes and "Moderate Guests"=Yes.
Also in the categories, I have gone to the specific category I want and have set in the category permissions the following:
Access Control Type=Access Level
Access Level=Public
User Groups Allowed To Post=Public (and others)
User Groups Allowed To Reply=Public (and others)

Is something else I can't see?
Can you please help?

Thanks

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #2 by rich
Go to Menus -> Kunena Menu and change the menu item New Topic from Registered to Public.

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #3 by impression
It is already set to public. Furthemore, I can see the whole forum as a public user. The problem is I can't see any button for creating a new post, which means that it is an inner option in Kunena and not a general access of Joomla to a component. Am I right?

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #4 by rich
If you've changed the menu item New Topic for public, guests can see this tab, indifferent if they have write access or not.
So it seems, you have something overlooked in your configuration.
Can you add the addres (without https and www, because links are not allowed for new registered users) to a forum category, which should be writable for guests, please?

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago - 2 years 7 months ago #5 by impression
(Thank you)

The URL is benefitsandwork dot co dot uk slash forum1 slash 10-dla-esa-queries-results
Normally you should be able to post comment there.
Last edit: 2 years 7 months ago by impression.

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #6 by rich
I've visited your page, but can't locality an error. Please create a configuration report , maybe I can see more.

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago - 2 years 7 months ago #7 by impression
I attach the anonymous configuration report.

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 128M | Max file upload: 20M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : fusion | author: joomladesigns.co.uk | version: 3.0.2 | creationdate: 30/04/2014

Kunena default template details : Blue Eagle5 jph | author: Kunena Team | version: 1.0.2 | creationdate: 2017-01-09

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.4 | 2021-04-04 [ Koios ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 5.1.2

Modules: None

Last edit: 2 years 7 months ago by rich. Reason: Configuration correctly inserted and text file removed

Please Log in or Create an account to join the conversation.

More
2 years 7 months ago #8 by rich
Your Blue Eagle is out of date and isn't adapted to the Kunena 5.x  series. Please update both, Kunena and Blue Eagle. t should solve your problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.600 seconds