×
Kunena 6.0.1.1 released (09 Jul 2022)

The Kunena team has announce the arrival of Kunena 6.0.1.1 [K 6.0.1.1] which is now available for download as a native Joomla extension for J! 4.1.x. This version addresses most of the issues that were discovered in K 6.0.1.1 and issues discovered during the development stages of K 6.0

Solved Bug in [code]...[/code] parser

More
1 year 4 weeks ago - 1 year 4 weeks ago #11 by joomlaworks
The fix makes BBCode convert the right way inside CKEditor. But the problem with server-rendered \[code\]...\[/code\] blocks remains.
Which means that there is still a bug in the BBCode parser which transforms \[code\]...\[/code\] saved in the database to <pre> HTML tags in the frontend.
Case in point: www.joomlaworks.net/forum/simple-rss-fee...d-loading-xml#178176
That post is 4 months+ old, I upgraded to Kunena v5.2.5 less than a month ago.

* I'm adding backslashes to the BBCode examples above as they break when rendering in this forum as well...
Last edit: 1 year 4 weeks ago by joomlaworks.

Please Log in or Create an account to join the conversation.

More
1 year 3 weeks ago - 1 year 3 weeks ago #12 by joomlaworks
So, fine, the CKEditor issue was resolved, but the server-side \[code\] parsing issue remains. Case in point: www.joomlaworks.net/forum/k2-en/46586-cu...ance?start=10#157674[/code]
Last edit: 1 year 3 weeks ago by joomlaworks.

Please Log in or Create an account to join the conversation.

More
1 year 3 weeks ago #13 by joomlaworks
It doesn't even work here...
Is there at least a handy/smart way to disable BBCode parsing altogether?

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #14 by joomlaworks
The issue persists in newer releases.

A PR has been submitted with the (simple) fix here: github dot com/Kunena/Kunena-Forum/pull/8877
Last edit: 4 months 2 weeks ago by joomlaworks.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #15 by joomlaworks
Sorry, but links are not parsed, thus the expanded github URL above.
Last edit: 4 months 2 weeks ago by joomlaworks.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #16 by xillibit

The issue persists in newer releases.

A PR has been submitted with the (simple) fix here: github dot com/Kunena/Kunena-Forum/pull/8877
 
The fix is merged now

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.072 seconds