×
Kunena 5.2.9 released and Kunena 6.0.0 (08 Jun 2022)

The Kunena team has announce the arrival of Kunena 5.2.9 [K 5.2.9] which is now available for download as a native Joomla extension for J! 3.10. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

The Kunena team has announce the arrival of Kunena 6.0.0 [K 6.0.0] which is now available for download as a native Joomla extension for J! 4.1.x. Only the module kunena latest and the discuss plugin which are still in beta are working in Joomla! 4.1 with Kunena 6.0.

Solved Problem loading CK Editor / Kunena 5.2.2 / Crypsisb4

More
1 year 4 months ago #1 by swillig
Hi there,

I have a problem with Kunena 5.2.2 / Joomla 3.9.24 and the Crypsisb4 Template and the ckeditor.

If i want to start a new topic, the ckeditor does not load an on debugging console I get the following error:
ckeditor.js:547 Uncaught TypeError: Cannot read property 'split' of undefined
    at Object.loadPart (ckeditor.js:547)
    at l (ckeditor.js:284)
    at a.<anonymous> (ckeditor.js:283)
    at a.l (ckeditor.js:10)
    at a.<anonymous> (ckeditor.js:12)
    at a.CKEDITOR.editor.CKEDITOR.editor.fire (ckeditor.js:13)
    at a.fireOnce (ckeditor.js:12)
    at a.CKEDITOR.editor.CKEDITOR.editor.fireOnce (ckeditor.js:13)
    at k (ckeditor.js:281)
    at Object.<anonymous> (ckeditor.js:281)


I assume that there is a conflict, but I don't get with wat.
There are no modules loaded, which do any other javascript except of the joomla core plugins/modules/header.

Here is my config report:
This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 1000M | Max file upload: 10000M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : VFT 2018 | author: S. Willig | REIKEM | version: 1.0.0 | creationdate: Oct 2018

Kunena default template details : Crypsisb4 | author: Kunena Team | version: 5.2.1 | creationdate: 2020-12-27

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.2 | 2021-01-13 [ Iris ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None


The Forum is private so I cannot give public access to this.

Has anyone an idea what I can do?
 

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #2 by rich
Exclude the file /media/kunena/core/js/ckeditor.js from your page optimization.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #3 by swillig
Thank you for your quick reply.

There is no page optimization (tool) active or installed.
Caching mode in Joomla is disabled.
The only thing - gzip was endabled, but disabling makes no difference.

Any other idea?

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago - 1 year 4 months ago #4 by xillibit
Hello,

Do-you checked in your Joomla! template if there are options for optimize JS ?

I don't provide support by PM, because this can be useful for someone else.
Last edit: 1 year 4 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #5 by swillig
Hi,
thanks for your reply.

It's a template written by myself and there is noch JS optimizing.
I'm loading jQuery (3.3.1 min) and Bootstrap (4.1.1) in the template.

Here is the link to v-f-t.de/media/kunena/core/js/ckeditor.js - and this is how it's loaded.

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #6 by rich
Is your forum correctly installed? The configuration report shows Kunena 5.2.2 but Crypsisb4 v 5.2.1
It should be the same version 5.2.2

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #7 by swillig
Good Morning :-)

it seems like it was not.
Thanks for that hint. Reinstallation of the forums package solved the problem.
Thanks a lot!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.287 seconds