×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

Solved Cannot attach jpg - mime type error

More
1 month 3 days ago - 1 month 3 days ago #1 by jtcarlin
Multiple users are reporting this, and I have experienced this myself.  The problem only seems to be with jpg's and only some of them.  Please see the error in the attachement.  It is:  Image MIME type (%s) is not allowed (%s).I have searched for everything.  Just updated blue eagle in case it was the issue (from 1.5 to 1.62) 

This problem occurs both on smart phones, and windows 10, but not all jpgs.  I am unsure why.  I have tried attaching a known problem jpg to this post and did not get the error, however I did not attach it.

I can upload known problem files to joomla itself via content-media without a problem.

 

Here is my report configuration:
This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct
        

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |
        

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 128M | Max file upload: 16M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : rt_protean | author: RocketTheme, LLC | version: 1.1.1 | creationdate: February 13, 2017

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.6.2 | creationdate: 2021-01-20

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.2 | 2021-01-13 [ Iris ]
        | Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 3.9

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 5.1.2

Attachments:
Last edit: 1 month 3 days ago by jtcarlin.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #2 by rich
Perhaps it is because the file info are deactivated on your server and in your Kunena configuration (tab Uploads) the option Check MIME Types is enabled.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #3 by jtcarlin
I have turned of Mime Type checking and the error still persisted. I will also note that I have had Kunena running without issue for many years. This just started happening recently. I am not sure exactly when since it is a slow time for pictures on our site in the winter.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #4 by jtcarlin
I turned off mime check in Kunena, and Joomla. However the error persists.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #5 by rich
Please, can you upload such an image, so I can test it? But pack it as a zip file, so that remain the original size and image info.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago - 1 month 2 days ago #6 by jtcarlin
I have attached the zip.

1)  This specific image is from a user using a samsung phone.  He received the error when trying to upload via mobile.  He was able to take a screenshot on his phone and upload that image without problem.  I also had him text me the original picture, I haved it to my iphone, saved it to my windows 10 machine, and recieved the same error when trying to upload it as an attachment from windows / chrome.

2)  I tried attaching a different image from my iphone, and received the error.  I transferred that same image to my windows 10 machine, and that same picture worked as an attachment just fine.

This is very odd behavior that is driving me crazy on what the cause may be.

 
Attachments:
Last edit: 1 month 2 days ago by rich. Reason: Tried to insert the attachment

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #7 by rich
hmm... interesting, your attachment will not be displayed below the message, so I have it for a short time inserted in your message to be able to download it.
I've tried it with the same settings for uploads as in your configuration report but can't reproduce this error.

This specific image is from a user using a samsung phone. He received the error when trying to upload via mobile. He was able to take a screenshot on his phone and upload that image without problem. I also had him text me the original picture, I haved it to my iphone, saved it to my windows 10 machine, and recieved the same error when trying to upload it as an attachment from windows / chrome. 

Please try to upload this image with another browser. Maybe the bug is the same problem as here:  www.kunena.org/forum/k-5-2-support/16055...ges-into-the-message

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago - 1 month 2 days ago #8 by jtcarlin
I have tested with Chrome and Safari on the iphone, and Chrome, Edge, and Firefox on Windows 10.  The error happens on all of them.  It would not appear it is related to the thread you referenced. 

I would be more than happy to setup an account for you on my site to see.  Thank you for your assistance.
Last edit: 1 month 2 days ago by jtcarlin.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #9 by rich

saved it to my windows 10 machine, and recieved the same error when trying to upload it

I meant this, not the phone browsers.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago - 1 month 2 days ago #10 by jtcarlin
Yes I tried in Chrome, Edge, and Firefox on Windows 10 with no success.
Last edit: 1 month 2 days ago by jtcarlin.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.596 seconds