×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

Solved Registered users cant upload images

More
4 years 2 months ago #1 by chrustik
Hi,

After upgrade, I get a problem with images upload with attachments function. When user trying to upload image, he got "COM_KUNENA_POST_ATTACHMENTS_ONLY_FOR_ADMINISTRATORS".

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : ajt005_j30 | author: AJoomlaTemplates.com | version: 3.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.3 | creationdate: 2015-06-29

Kunena version detailed: Kunena 4.0.3 | 2015-06-29 [ Possagno ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIM 3.4

Third-party SEF components: None

Plugins: None

Modules: Ku

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #2 by 810
go to backend -kunena - configuration - uploads - Set "Allow Image Uploads" to "Registered Users"

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #3 by chrustik
I know. This is already set in my configuration, but it not working after upgrading.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #4 by chrustik
also uploading not working if I choose "All". Upload working only admin users.

Please Log in or Create an account to join the conversation.

More
4 years 2 months ago #5 by rich
You have in your setting:

Allow Image Uploads = Registered Users
Allow File Uploads = Administrators

It's the same bug
github.com/Kunena/Kunena-Forum/issues/3299

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.099 seconds