×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved Strange installation problem

More
4 years 1 month ago #1 by dimoss
Hi

I am trying to install the latest Kunena on a J!2.5.28.
Unfortunately the installation stop and I get error 500 before the installation popup open and continue with the rest.
I enabled the debug to Maximum and when I returned I got these errors:

Sorry, installation failed with following error:

Notice: Use of undefined constant KPATH_ADMIN - assumed 'KPATH_ADMIN' in /opt/lampp/htdocs/pdan/administrator/components/com_kunena/install/schema.php on line 13

Notice: Use of undefined constant KPATH_ADMIN - assumed 'KPATH_ADMIN' in /opt/lampp/htdocs/pdan/administrator/components/com_kunena/install/schema.php on line 14

Notice: Trying to get property of non-object in /opt/lampp/htdocs/pdan/administrator/components/com_kunena/install/schema.php on line 401

Warning: Invalid argument supplied for foreach() in /opt/lampp/htdocs/pdan/administrator/components/com_kunena/install/schema.php on line 422

Fatal error: Class 'KunenaRoute' not found in /opt/lampp/htdocs/pdan/administrator/components/com_kunena/install/sql/install/php/sampledata.php on line 147


I am at a loss because when I tried to another J!2.5.28 it worked like a charm.
I also tried in a clean installation and again worked like a charm.

Can u help me pls?

Thanks!

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago #2 by rich
Replied by rich on topic Strange installation problem
Clear the Joomla cache and try it again.

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago #3 by dimoss
Replied by dimoss on topic Strange installation problem
Solution found..:-)
I have Fabrik installed.
I had to disable Fabrik system plugin and move it on top of the order before I install Kunena.
I did it and the installation done!!

P.S. I share it just in case someone else has the same problem
The following user(s) said Thank You: rich

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago #4 by rich
Replied by rich on topic Strange installation problem

P.S. I share it just in case someone else has the same problem


Thank you! :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.072 seconds