×
Blue Eagle 5 v1.5.3 has been Released (31 Mar 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.3 which is now available for download. This version addresses most of the issues that were discovered in development.

Question Install/Update Failure 4.0.10

More
3 years 10 months ago #1 by NAIDW
Getting error message please help? Are we going to lose our content. The closest resolved issue i saw was to uninstall joomla and reinstall. We have no idea how to do this our site has many pages and members and scared something can go wrong?

We are a nonprofit with volunteers and the person that was helping is ill can someone please help us?

Thank you
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #2 by 810
Replied by 810 on topic Install/Update Failure 4.0.10
Try first clean cache. Then go to administrator/index.php?option=com_kunena&view=install
Else you need to disable all none joomla/kunena plugins, then install, after install enable the plugins.

write down somewhere which plugin you have disabled.
Last edit: 3 years 10 months ago by 810.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #3 by NAIDW
Replied by NAIDW on topic Install/Update Failure 4.0.10
Did all this still nothing.
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #4 by 810
Replied by 810 on topic Install/Update Failure 4.0.10
try with an other browser

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #5 by NAIDW
Replied by NAIDW on topic Install/Update Failure 4.0.10
Nothing? Tried on chrome, firefox and Safari?

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #6 by steve30000
I had this problem last night as well and seemed to solve it by clearing the Admin cache as well.



I hadn't realized there was a separate admin cache until reading it in someone else's post.
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #7 by NAIDW
Replied by NAIDW on topic Install/Update Failure 4.0.10
I have done that also and still wont worrk?

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #8 by sozzled
I hit this problem a lot! Today I was updating a website that was using K 3.0.8 and I was installing K 4.0.10. Obviously I took a lot of precautions before starting the update (backup the site, copy the backup off-site). Anyway, I used my usual installation method—upload file—the Kunena installer halted and, the only way I could recover, was to use the browser back-button. :pinch: :dry:

Ah, but all was not lost! Even though the "Kunena installer" had failed, go to Components » Kunena Forum » Configuration and, sure enough, the rest of the installation went ahead. :woohoo:

I've never run into the problem of having to "clear the cache". I realise this is the answer/response given most often by the developers but, to be totally honest with everyone, I've never had to do it! (And, as for trying with a different kind of browser, that sounds a bit absurd to me.)

So, maybe I'm just one lucky person out of 30,000? Or maybe I have more patience than other people?
Last edit: 3 years 10 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #9 by mw911
Replied by mw911 on topic Install/Update Failure 4.0.10
Looks like I am running into the same sort of problem. Updated to 4.0.10 and now my categories all say they are Orphaned in the administrator. I can see them in the live forum and click on them but get a notice of "Access Denied-You do not have permissions to access this page.".

If I click on the category in the administrator, I get this error: "Call to a member function get() on string".

If I try to unpublish the category, I get a really scary SQL error, the start of which says: Duplicate entry '3' for key 'PRIMARY' SQL=INSERT INTO `#__kunena_categories`. This is followed by a whole lot of database speak.

I am attaching my configuration report.

File Attachment:

File Name: Kunena_Report.txt
File Size:11 KB


I have placed the forum offline for the moment.
I have cleared all of the caches and tried other browsers.

I am afraid if I uninstall Kunena that I will lose all my forum content. Is this correct?

Thanks for any assistance,

Mike
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #10 by 810
Replied by 810 on topic Install/Update Failure 4.0.10
"Call to a member function get() on string". is a php7.0.6 bug.

So i suggest to go to php 5.6
The following user(s) said Thank You: mw911

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.455 seconds