×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved Attached images not shown since server switch

More
4 years 6 months ago - 4 years 6 months ago #1 by betteryouthanme
Hey lads,
i recently switched the webserver from IIS7 to Apache.

Exported/Imported the sql databases,
Copied the joomla files,
made adjustments to the configuration.php of Joomla (sql database, etc.)

Now the site works like before, but attached images are not shown or if they are distorted as you can see here:
www.rprclan.com/forum/6-off-topic/9-make...mile?start=504#14769 (not shown)
www.rprclan.com/forum/25-history/922-tod...tory?start=366#14766 (distorted)

Any idea what went wrong, or there's something not configured correctly?

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 2000 seconds | Max execution memory: 128M | Max file upload: 300M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : purity_III | author: JoomlArt.com | version: 1.1.5 | creationdate: July 2015

Kunena default template details : Crypsisb3 | author: Kunena Team | version: 4.0.9 | creationdate: 2016-01-21

Kunena version detailed: Kunena 4.0.10 | 2016-02-18 [ Villavicencio ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 3.8

Third-party SEF components: None

Plugins: Search - Kunena Search 3.1.2 | Content - Kunena Discuss 3.1.2

Modules: Kunena Latest 3.1.2.1 | Kunena Login 3.1.2


Thanks a lot :)

Two things fill the mind with ever new and increasing wonder and awe - the starry heavens above me and the moral law within me. Immanuel Kant
Last edit: 4 years 6 months ago by betteryouthanme.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago - 4 years 6 months ago #2 by rich
Your setting is Protect Attachments = Yes. It seems that all images which one has uploaded after this setting are broken. Older images are displayed.
Go to "media -> kunena -> attachments -> Folder with numbers" (the number is the user ID). You find files (such as the image below). Try, whether you can open this files with your browser.
Attachments:
Last edit: 4 years 6 months ago by rich.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #3 by betteryouthanme
now if i try e.g
www.rprclan.com/media/kunena/attachments...ef49b07fe6f62e6dc8de

i get:
<html>
<head>
<meta name="viewport" content="width=device-width; height=device-height;">
<link rel="stylesheet" href="resource://gre/res/ImageDocument.css">
<link rel="stylesheet" href="resource://gre/res/TopLevelImageDocument.css">
<link rel="stylesheet" href="chrome://global/skin/media/TopLevelImageDocument.css">
<title>1bc0249a6412ef49b07fe6f62e6dc8de (JPEG-Grafik, 800&nbsp;×&nbsp;569 Pixel)</title>
</head>
 
<body>
<img src="https://www.rprclan.com/media/kunena/attachments/169/1bc0249a6412ef49b07fe6f62e6dc8de" alt="Die Grafik &quot;https://www.rprclan.com/media/kunena/attachments/169/1bc0249a6412ef49b07fe6f62e6dc8de&quot; kann nicht angezeigt werden, weil sie Fehler enthält.">
</body>
 
</html>

I always thought the files without an extension type (like .jpg) are non-images. (like .7z, .exe, ...)
And it was working on the old webserver.. I don't understand this

Two things fill the mind with ever new and increasing wonder and awe - the starry heavens above me and the moral law within me. Immanuel Kant

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #4 by rich
My browser says The graphic cannot be displayed because it contains errors.
You have a backup? Then try whether the images from the backup are correct.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #5 by betteryouthanme
now yes i have a backup on my local drive and these images are displayed all correctly with Firefox.

There's something wrong with FTP upload. After uploading the file size has changed:



Comparing both files with HEX Editor shows some differences..

:huh:

Two things fill the mind with ever new and increasing wonder and awe - the starry heavens above me and the moral law within me. Immanuel Kant
Attachments:

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #6 by rich
I've tested it with FileZilla and can confirm, it breaks the images. But if you upload the folder "attachments" as zip file and unzip on the server, then it works.

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago #7 by betteryouthanme
That did the trick :) Thanks a lot!!

Just for explanation, why some files are that encrypted? Is there a setting in the back-end?

Two things fill the mind with ever new and increasing wonder and awe - the starry heavens above me and the moral law within me. Immanuel Kant

Please Log in or Create an account to join the conversation.

More
4 years 6 months ago - 4 years 6 months ago #8 by rich
The attachments are encrypted only if is selected "Protect Attachments = Yes" (Configuration -> Uploads -> Protect Attachments). It protects attachment files from direct access by entering URLs like websiteaddress/media/kunena/attachments/image.png.
Last edit: 4 years 6 months ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.816 seconds