×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Solved Annoying issue with system messages

More
6 years 2 weeks ago - 6 years 2 weeks ago #1 by Nova
Hi
I've installed Kunena , configured etc, but unfortunatelly I noticed that after sending EVERY post on my new forum on the top of kunena appear "system message" info (on joomla green background). Something like this (I will try to translate it from my native language)

"MESSAGE
Your message/post has been sucessfully sent"

This happen every time after sending single post. Its very frustrating.

I have latest Kunena 4.0.5, latest joomla 3.4.3. In Kunena configuration there is disabled subscription, also disabled debugging mode.


My question is HOW TO DISABLE these ugly notifications in kunena?



Attachments:
Last edit: 6 years 2 weeks ago by Nova.

Please Log in or Create an account to join the conversation.

More
6 years 2 weeks ago #2 by 810
add this on your joomla template css:
#system-message-container {display: none;}

Please Log in or Create an account to join the conversation.

More
6 years 2 weeks ago - 6 years 2 weeks ago #3 by Nova
Thx for your reply 810 , but believe me... disabling system messages completely in joomla is not good idea. Many other plugins or components sometimes use it to inform user what is going on.
So this is definitely bad idea.

I think it should be correctly programmed inside of kunena. I still dont believe that there is no option to change that. Otherwise i will be forced to install phpbb3 - but i dont like this stuff.

Any other ideas? workarounds?
Last edit: 6 years 2 weeks ago by Nova.

Please Log in or Create an account to join the conversation.

More
6 years 2 weeks ago #4 by rich
You can easily disable it. Go in backend to "Extensions > Language(s) > Overrides > (Filter)-Site > New". Enter in the field Language Constant this code:

COM_KUNENA_POST_SUCCESS_POSTED

Let empty the text field and save it. That's all.

Please Log in or Create an account to join the conversation.

More
6 years 2 weeks ago #5 by Nova
Hmmm. thats very interesting method..it even works!
I understand that i could delete also other infos in the same way..hmm..

Could you tell me what exactly file i'm editing ? (i prefer do that directly in notepad)
I cant find it in ...\administrator\components\com_kunena\language\my_language\file
There is no such entry like COM_KUNENA_POST_SUCCESS_POSTED

Please Log in or Create an account to join the conversation.

More
6 years 2 weeks ago #6 by rich
You find it in "root/language/your language/xx-XX.com_kunena.controllers.ini"

Fronten languages are in "root/language"
Backend languages are in "root/administrator/language"
The following user(s) said Thank You: Nova

Please Log in or Create an account to join the conversation.

More
6 years 2 weeks ago - 6 years 1 week ago #7 by Nova
You are just genius..thx !


ps. Hey guys!
There seems already to be implemented option fory this in Kunena Panel -> configuration -> site (tab) -> show statement/message (look for something like that i can see only my polish language just above show avatars) and check NO.

Afer that you will no longer see system infos in kunena !
Last edit: 6 years 1 week ago by Nova.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.100 seconds