×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Right-justified and punctuation jumping?

More
7 years 4 months ago #1 by Jenney
Hi all

Ive just installed the latest version for my daughters joomla 3.3 site, however everything seems justified right and when you try to add punctuation to anything posts or profile, the punctuation jumps to the beginning of the sentence.

Any idea why or how I can fix it please?

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago #2 by sozzled
G'day, Jenney, and welcome to the community.

I could take a few wild stabs in the dark but I really would only be guessing. Rather than trying to guess what you mean by "everything seems to be justified right" and the bizarre behaviour of things "jumping" aound when you add punctuation, it may help if you read the important information posted at the top of this page and, then, maybe if we had some extra details about your website we may be able to see what's causing this behaviour.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago #3 by Jenney
Hope this helps.




This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 64M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : FNB | author: TemplateToaster | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.5 | creationdate: 2014-03-09

Kunena version detailed: Kunena 3.0.5 | 2014-03-09 [ Invecchiato ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago - 7 years 4 months ago #4 by sozzled
Thank you for your configuration report containing the link to your website. :)

The problem of your text being right-justified and oddly punctuated - oddly, that is, if your native language is English - is not limited just to Kunena. All the text on your home page is also right-justfied and the punctuation is at the beginning of the sentences.

I suspected that you were using a RTL (right-to-left) Joomla template and, on examination of your site, you are using RTL. I did not want to leap to that conclusion until I had seen the evidence of the problems.

(I must confess that when I read "jumping punctuation" I actually imagined that question marks and semi-colons were leaping about in wild animated ways over your website and I had to see this for myself! :D)

In your case, changing the direction is fairly easy (it's a one-line change) which will correct the odd punctionation. Alternatively, use a template that was designed for languages that are written left-to-right.

The text alignment (which is currently right-justified) is a little trickier. Your Joomla site template text alignment rules explicitly define text alignment in several places; finding them all will take a bit more time. Alternatively, a different Joomla template will address that issue, too (see My Joomla site template makes a mess of Kunena ...

Does this help?
Last edit: 7 years 4 months ago by sozzled.
The following user(s) said Thank You: Jenney

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago #5 by Jenney
Thank you so much.. I feel like an idiot.

When I exported the template, i accidentally clicked the RTL button and didnt realise it. Ive re exported and reinstalled the template and all the issues are fixed.

Thanks SO much.

Now if I can fix my other joomla issue (non forum related though so I wont post it here ) , Ill be all set.

Thanks again!!!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.176 seconds