×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Bug Help upgrading 3rd-party K 2.0 template to make it compatible with K 3.0.4

More
7 years 8 months ago #1 by plezi69
Hello everyone. I am trying to upgrade my current template to work with joomla 3.x and the latest kunena. So far, everything is going except for this line of codes <?php foreach ($tabmodules as $tabmodule) : ?>
<?php if (JDocumentHTML::countModules ( 'kunena_tab_'.$tabmodule )) : ?>
<a id="tktab-<?php echo $tabmodule; ?>" href="#" rel="tk-tab-<?php echo $tabmodule; ?>"><span class="tk-fronttab-<?php echo $tabmodule; ?>">. that is showing this error "Strict Standards: Non-static method JDocumentHTML::countModules() should not be called statically, assuming $this from incompatible context. Any ideas on how to fix this issue?

Thanks in advance for your help

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago - 7 years 8 months ago #2 by sozzled
G'day, plezi69, and welcome to Kunena.

You posted your question in the K 3.0 Blue Eagle Templates category which is for asking questions about the Kunena Blue Eagle template.

Please note the information posted at the top of this page:

This category is for discussing issues with the K 3.0 Blue Eagle template.

As general background, My Joomla site template makes a mess of Kunena .

We do not answer questions about other templates for Kunena here.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.


Are you trying to upgrade an old Kunena Blue Eagle template? It may help if you watched the video so that we know more about your situation.
Last edit: 7 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago - 7 years 8 months ago #3 by plezi69
Hi and thank you for the prompt response. I am actually trying to upgrade a customize template. I did not notice this rule for this section of the forum so I apology.

Here's the configuration report.

Thanks

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 128M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : jsn_air_pro | author: JoomlaShine.com | version: 2.0.1 | creationdate: Unknown

Kunena default template details : Bloggy - Kunena 2.x | author: www.TemplateKunena.com | version: 1.0.6 | creationdate: 15.12.2012

Kunena version detailed: Kunena 3.0.4 | 2013-12-22 [ Ukko ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: Jomsocial 2.8.4

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1 | Kunena Stats 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1

Last edit: 7 years 8 months ago by plezi69.

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago #4 by 9themestore
Hi plezi69,

You are using a commercial template. I think you should contact with the template club, they will support you upgrade it.

- Please provide your site url if it has been lived.
- Please share tip if it worked fine with you.
- Don't be shy about using the "Thanks" button below if you found my comment helpful :)

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago - 7 years 8 months ago #5 by sozzled
Yes, this is not a template designed, developed or maintained by the Kunena team.

This topic was posted in the wrong category.

*** Topic moved ***

Please contact the author of the template you are using to find out if there is a version compatible with K 3.0.4 or, alternatively, use the K 3.0.4 Blue Eagle template.
Last edit: 7 years 8 months ago by sozzled.
The following user(s) said Thank You: plezi69

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago #6 by plezi69
Thank you guys. Unfortunately the developer is not responsive. A lot of its customers are having the same issues for a template that they have purchased and the developer disappear. Thanks anyway :(

Please Log in or Create an account to join the conversation.

More
7 years 8 months ago - 7 years 8 months ago #7 by sozzled
I am marking this topic closed (unresolved).

My advice is to use the K 3.0.4 Blue Eagle template or find an alternative template provider - see the advertisements on this site. ;)
Last edit: 7 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.230 seconds