×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Error installing com_kunena

More
5 years 1 month ago #1 by originalhandy
tl;dr
I have a VPS and the index.php's where getting compromised.
Was advised to delete files and keep configuration.php and reinstall components / plugins.
All my Joomla plugins/components have re installed fined except Kunena.
I downloaded the zip and extracted from here, all installed except com_kunena.

I am using the latest Joomla, latest Kunena and PHP 5.3.29

"

JLIB_INSTALLER_ABORT_COMP_INSTALL_ROLLBACK

Error installing component

Kunena Forum"

Please Log in or Create an account to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #2 by sozzled
Replied by sozzled on topic Error installing com_kunena

originalhandy wrote: I downloaded the zip and extracted from here, all installed except com_kunena.

Why did you do it that way instead of following the K 3.0 Upgrade Guide ? :dry:

Who advised you to delete the Kunena files but keeping the configuration.php? This has never been the official advice from the Kunena team.
Last edit: 5 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #3 by originalhandy
I did it for the whole Joomla not just Kunena. Something was changing files that had to have been on the site. Per Joomla's own disaster recovery docs.joomla.org/Security_Checklist/You_h...en_hacked_or_defaced

A Safe route for disaster relief

save the configuration.php file and your images and personal files one by one, (not the folder as it may contain unwanted files)
wipe the entire folder where Joomla! is installed
upload a new clean full package latest version of joomla 1.5.x or Joomla 2.5.x, joomla 3.x (minus the install folder)[2]
reupload your configuration file & images.
reupload or reinstall the latest versions of your extensions , templates (even better is to use original clean copies to ensure that the hacker/defacer did not leave any shell script files in your site)

Last edit: 5 years 1 month ago by originalhandy.

Please Log in or Create an account to join the conversation.

More
5 years 1 month ago - 5 years 1 month ago #4 by originalhandy
For anyone with this issue I had to drop Kunena from the assets table then installed the component again and it works fine.
Last edit: 5 years 1 month ago by originalhandy.
The following user(s) said Thank You: sozzled

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.073 seconds