×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Update options for PHP 5.2 users?

More
6 years 3 weeks ago #1 by Rooster
I'm wondering if anyone has any ideas/workarounds for the Kunena 3.x versions which require PHP 5.3+.

Our site is getting generic posts somehow (injection??) that contain messages like "Cheer for every folks, my nick is Howard
I wish to inform You chill for each of You :p" and after numerous google searches the common denominator seems to be they are all running Kunena forums. I'm not sure of the version, but I KNOW I'm running the older 2.x (latest/last 2.x release) and 3.x has been out for quite some time. My host runs PFP 5.2.x and has had no interest in updating to a newer version as it would throw more people into incompatibility situations than those who run applications requiring 5.3.x..

So I'm wondering if anyone else here might've been in a similar situation and took a gander at the Kunena 3.x code and edited out the PFP 5.3 differences to make it work with PFP 5.2...

Please Log in or Create an account to join the conversation.

More
6 years 3 weeks ago - 6 years 3 weeks ago #2 by sozzled
K 3.0 requires PHP 5.3. See Technical Requirements . Sorry, that's just the way it is.

I think you need to shop around for a new webhost, someone who is prepared to keep their software up-to-date. That's what most of us do when we're in a situation like yours.
Last edit: 6 years 3 weeks ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 3 weeks ago - 6 years 3 weeks ago #3 by Rooster
Thanks for the prompt reply, appreciated! I've been with this company for over 10 years, really hate to have to up and move just because of this reason, almost seems silly. Thought it would be fairly simple to edit code to make it 5.2 compat - I mean how vastly could PHP have changed from 5.2 to 5.3.. But if that's not the case, I suppose I could try continuously nagging my host, lol :( Thanks for the info, anyway, you can go head and close the topic if ya like. Preciate it, as always!

*** Topic archived - as requested - by moderator ***
Last edit: 6 years 3 weeks ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.075 seconds