×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Fatal Installation Errors Kunena 3.0.4 on Joomla 3.2.1

More
6 years 6 months ago - 6 years 6 months ago #1 by tomfuller2
Kunena 3.0.4 existed on this 2.5.17 site. When upgraded to 3.2.1 the component install failed when accessing it on the admin side.

These were the main errors:

Notice: Use of undefined constant KPATH_ADMIN - assumed 'KPATH_ADMIN' in D:\http\edweb\news\administrator\components\com_kunena\install\schema.php on line 12

Warning: DOMDocument::load() [domdocument.load]: I/O warning : failed to load external entity "file:///D:/http/edweb/news/administrator/KPATH_ADMIN/install/install.xml" in D:\http\edweb\news\administrator\components\com_kunena\install\schema.php on line 206

Fatal error: Class 'KunenaFactory' not found in D:\http\edweb\news\administrator\components\com_kunena\install\model.php on line 699

I uninstalled and reinstalled, making sure all plugins, component, and package had been removed.

I also have reviewed other posts on this subject but none provided enough information or results to solve my problem.

I also had checked to be sure the System Kunena plugin was published, which it was.

Thanks for your help.

Database version: 5.1.53-community-log
Php: 5.3.4
Joomla: 3.2.1

Edit: I notice that with every install try a row is added to the #__kunena_version table:

3.0.4 2013-12-22 2014-01-28 Ukko upgradeDatabase
Last edit: 6 years 6 months ago by tomfuller2.

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #2 by sozzled
Long time no see, Tom. :) I must candidly admit that my experience in running Joomla under MS Windows is extremely limited. If we are talking about running an Apache server stack on a PC-based server, I have some experience; if we're discussing IIS then I have no experience at all.

Aside from that, I suggest you look at the topic Warning: DOMDocument::load(): I/O warning : failed to load external entity "../public_html/administrator/KPATH_ADMIN/install/install.xml" in ../public_html/administrator/components/com_kunena/install/schema.php on line 206 which I think covers your problems, too. I hope this helps.

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #3 by tomfuller2
Howdy - yes, it's me again after a long time!

We actively use Kunena on a couple of sites - the one in question is on an intranet behind a firewall.

I've tried following the paths of the errors and overcoming them but have lead to dead ends.

The post you cite was one I reviewed. No competing components and the Kunena system plugin was published. This same forum worked great on the same site under 2.5.17. It was when we upgraded to 3.2.1 that the problem has come about.

It's running on a XAMP stack on a Windows machine.

Here's what I am going to try: backup the db, uninstall and remove the db, fresh install - see if that works, then restore the old db.

I'll let you know!

Please Log in or Create an account to join the conversation.

More
6 years 6 months ago #4 by tomfuller2
So just to let you know - that worked.

I removed all traces of Kunena - all files and all tables.

Installed fresh - worked.

Restored the db except the versions table, which I left intact.

Now all is good.

No idea why that worked or why it didn't before!

Cheers.

Tom

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.122 seconds