Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Please Read This First:

This is a community-driven self-help category to ask questions about designing or developing your own Kunena template. Please be aware that there are rules that apply to topics posted in this category:

Do not use this category for:
  • asking questions about how to make simple changes to a template designed by the Kunena project team (use K 3.0 Templates instead);
  • advertising your own template designs.

Topics that do not meet the above guidelines may be removed without notice.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question All Kunena categories display the same SVG icon

More
1 month 3 weeks ago #1 by shepherdsstream
Step to reproduce issue:

- Add SVG icons for categories by the guide provided here:
www.kunena.org/docs/en/custom adjustments/category-icons


- Expect: On the index page, expect all category icons display correctly

- But: it display the same icon for all categories.

To quickly fixed this issue:
I customized the file:
components/com_kunena/template/aurelia/layouts/category/index/default.php

Replace the code line:
<?php echo $this->getCategoryLink($category, $this->getCategoryIcon($category), '', null, true, false); ?>

With below one:
<?php 
                                $icon = $this->getCategoryIcon($category);
                                $icon = str_ireplace('_Image1', '_Image'.$category->id, $icon);
                                echo $this->getCategoryLink($category, $icon, '', null, true, false); 
                                ?>

I think that this issue should be fixed in the function getCategoryIcon.

Please Log in or Create an account to join the conversation.

Time to create page: 0.460 seconds