×
Kunena 5.1.9 Released (15 Feb 2019)

The Kunena team has announce the arrival of Kunena 5.1.9 [K 5.1.9] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a maintenance release.

× Please Read This First:

This is a community-driven self-help category to ask questions about designing or developing your own Kunena template. Please be aware that there are rules that apply to topics posted in this category:

Do not use this category for:
  • asking questions about how to make simple changes to a template designed by the Kunena project team (use K 3.0 Templates instead);
  • advertising your own template designs.

Topics that do not meet the above guidelines may be removed without notice.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Missing Kunena menu (with error) and main menu reformated

More
3 months 1 week ago #1 by asajay
Greetings,
I just installed the latest (and first install) of Kunena on our web site at www.spokares.org/index.php/forum
I have used Kunena previously, on older Joomla v1 and v2 websites. This is my first v3 website to have Kunena added.

When loaded, the main menu changes from a horizontal format to a vertical (stacked) format, and the Kunena menu doesn't show up at all, giving an error:
Rendering Error in layout Widget/Menu: Call to a member function get() on null. Please enable debug mode for more information.

If I turn on Debug, I get this:
Notice: Undefined variable: menuType in /home/aressc/public_html/templates/js_wright/wright/html/joomla_3.0/mod_menu/default_component.php on line 37

Notice: Undefined variable: params in /home/aressc/public_html/templates/js_wright/wright/html/joomla_3.0/mod_menu/default_component.php on line 42

Rendering Error in layout Widget/Menu: Call to a member function get() on null in /home/aressc/public_html/templates/js_wright/html/mod_menu/default_component.php on line 16
Layout was rendered in /home/aressc/public_html/components/com_kunena/template/crypsis/layouts/widget/menu/default.php on line 121

If I turn OFF the menu in the Kunena template, then the main menu renders properly but then I'm left without a Kunena menu.

I'm running Joomla 3.9.0 with PHP 7.2 and pretty much a default Joomlashack Wright framework template.

I could use some guidance on why this is not working as expected. Any ideas what I should look at first?
Thank you,
Asa Jay

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #2 by asajay
I've still not found a resolution for this. Can anyone recommend what to look at? Is there something I should look at in the configuration? Or is it really a problem with the Joomla template?

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago - 2 months 1 week ago #3 by rich
Last edit: 2 months 1 week ago by rich.

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #4 by asajay
Rich,
You are a -star-!

Although my Joomla install was up-to-date and my install of Kunena was up-to-date (got the latest yesterday), I found my install of the Wright template was a few versions behind (and I never got the update notice). I manually did a [Search for Updates] and installed the latest Wright template. From the links you provided that appeared to potentially be the resolution, and I'm happy to say, it was.

Now I can go about configuring the new forum and get it into use!
Thank you so much for the pointer, I would not have thought to look into Git. Greatly appreciated.
Asa Jay

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.105 seconds