×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Please Read This First:

This is a community-driven self-help category to ask questions about designing or developing your own Kunena template. Please be aware that there are rules that apply to topics posted in this category:

Do not use this category for:
  • asking questions about how to make simple changes to a template designed by the Kunena project team (use K 3.0 Templates instead);
  • advertising your own template designs.

Topics that do not meet the above guidelines may be removed without notice.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Issues After Upgrading from 4 to 5.0.4

More
3 years 9 months ago - 3 years 9 months ago #1 by ThePowersThatBe
I just updated from the last 4 version to 5.0.4. On topic pages the buttons are now misaligned and there is an extra blank box after each attachment thumbnail:



If I try to make any changes to the Template settings on the admin side, I get this error (Operation Failed: Failed to write configuration file.):



If I log into the front end with an admin account, the avatar is not displayed:



And I get this "Warning Rename failed." message on every page load.



If I log into the front end with a regular account, the avatar is shown correctly and there is no warning message.

Thanks for reading. Any guidance would be appreciated!
Attachments:
Last edit: 3 years 9 months ago by ThePowersThatBe.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #2 by ThePowersThatBe
I resolved the issues with the configuration file and avatars. When the new version of Kunena installed, the cache and /components/com_kunena folders and files were created with incorrect user permissions. I manually configured the permissions and those errors are fixed.

Under "Templates, Crypsis, Basic Settings" I changed "Load Bootstrap css" to YES and that helped with button icons, however the misalignment problem still persists:

Attachments:
Last edit: 3 years 9 months ago by ThePowersThatBe.

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #3 by rich
Can you post a link please? But we would need also an account (minimum moderator), otherwise we can't see the buttons.

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago - 3 years 8 months ago #4 by ThePowersThatBe
It is a private forum, I could message you an account but I cannot post a link. I do not see any way to message you here.

I am using Favourite theme on my site.

demo.favthemes.com/favourite/

The buttons also appear this way at the bottom of each post when logged in to a regular account.

Attachments:
Last edit: 3 years 8 months ago by ThePowersThatBe. Reason: cannot submit new posts with attachments, editor page just reloads instead of posting, I have to submit plain post and then edit post to add attachments here?

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #5 by rich
You can use the confidential tags, then only you and we moderators can see it.
The following user(s) said Thank You: ThePowersThatBe

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #6 by ThePowersThatBe
OK, thank you.

This message contains confidential information

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago - 3 years 8 months ago #7 by rich
Try it with this codes:

a.btn.dropdown-toggle {
    margin-bottom: 0px !important;
}
a.btn {
    margin-top: 0px !important;
}
button.btn {
    margin-bottom: 0px !important;
    margin-right: 0px;
}
a.btn.openmodal {
    margin-top: 0px !important;
}

Optional you can also add this codes, this will remove the white shadow. But for me it looks better without this codes.

.layout#kunena a.disabled {
    box-shadow: none !important;
}
.layout#kunena .btn {
    box-shadow: none;
}
Last edit: 3 years 8 months ago by rich.

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #8 by ThePowersThatBe

rich wrote: Try it with this codes:

a.btn.dropdown-toggle {
    margin-bottom: 0px !important;
}
a.btn {
    margin-top: 0px !important;
}
button.btn {
    margin-bottom: 0px !important;
    margin-right: 0px;
}
a.btn.openmodal {
    margin-top: 0px !important;
}

Optional you can also add this codes, this will remove the white shadow. But for me it looks better without this codes.

.layout#kunena a.disabled {
    box-shadow: none !important;
}
.layout#kunena .btn {
    box-shadow: none;
}

What file does this go in?

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #9 by rich
Try it in your less. www.kunena.org/docs/en/manual/backend/templates/edit-less
You can also add the codes at the end of your Joomla! template.css
The following user(s) said Thank You: ThePowersThatBe

Please Log in or Create an account to join the conversation.

More
3 years 8 months ago #10 by ThePowersThatBe
Thank you, I added the code to crypsis.less and the buttons are aligned again.



Your link with https went to 404 error page, but I found the page by going to Documentation > Manual > Templates > Edit Less . Or remove SSL and use only http and the link works.
Attachments:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 2.306 seconds