×
Kunena 5.2 Beta 1 Released (Yesterday)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Please Read This First:

This is a community-driven self-help category to ask questions about designing or developing your own Kunena template. Please be aware that there are rules that apply to topics posted in this category:

Do not use this category for:
  • asking questions about how to make simple changes to a template designed by the Kunena project team (use K 3.0 Templates instead);
  • advertising your own template designs.

Topics that do not meet the above guidelines may be removed without notice.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Template problems with site on different hosting provider

More
3 years 9 months ago #1 by rob parker
We've just transferred our website to a new hosting provider, and while checking that everything works before pointing our DNS record at the new site we've found some problems. One very bad one is that the Forum component is not loading all its required CSS and JS files.

We did the transfer by copying all files and the database from the current site to the new site - files by FTP download to local system, then upload to new; database by export and import.

Both hosts are running PHP v5.6; old host has MySQL v5.1, new host has MySQL v5.6. Joomla version is 3.4.3; Kunena component version is 4.0.3

The problem appears to be that the new site fails to load several CSS and JS files; with the Blue_Eagle template selected, there are 4 CSS files that are not loaded (all in the /components/com_kunena/template/blue_eagle/css folder), and 5 JS files that are not loaded (3 in the /media/system/js folder, 2 in the /media/kunena/js folder); The missing files are:
mediaboxAdv-min.css
kunena.forum-min.css
kunena.responsive-min.css
kunena.default-min.css
mootools-core.js
core.js
mootools-more.js
mediaboxAdv.js
default.js

We've not been able to find anything that might explain this behaviour. Any suggestions would be gratefully received.

Rob

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #2 by rich
It seems, some files are broken during the transaction. But your Joomla and Kunena versions are out of date and a upgrade should solves the problem. You should do it also for security reasons.

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #3 by rob parker
Thanks Rich. Indeed, there was a file in the blue_eagle folder that was not uploaded correctly. Fixed that, and all is now good.

We're aware that we need to do some upgrades, and it's on our to-do list. We plan to run them on a copy of our site first, to ensure that nothing breaks; couldn't do that with current provider as not enough space - it's a long and sorry story. WE'll get there soon now we're with a new provider.

Rob

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.086 seconds