×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Undefined property: KunenaConfig::$changename in...

More
5 years 11 months ago #1 by Django29
Hi
New install Kunena 3.0.6 on Joomla 3.3.6 and Siteground.

The problem : in Kunena in frontend, between the category name and the subject, I have this error message :
Notice: Undefined property: KunenaConfig::$changename in /home/myaccount/public_html/mysite/components/com_kunena/template/orao/html/topic/edit.php on line 70
style="display:none;">

This line 70 :
<?php if ( $this->me->userid && !$this->config->changename && !$this->category->allow_anonymous ): ?>style="display:none;"<?php endif; ?>>

A solution ?

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #2 by Mortti
Try to use Default Kunena Template (Blue Eagle) from Kunena Team screencast.com/t/DJc6ts32VoJh
Orao is not from Kunena Team and it may not be quite up to date?

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #3 by Django29
Thanks for answering, but the template Orao is more suitable for my website, and after I selected "System default" for Global configuration/Server/Error reporting, the error message disappeared.
I hope the origin of this message will not be a problem later...

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #4 by Mortti

Django29 wrote: Thanks for answering, but the template Orao is more suitable for my website, and after I selected "System default" for Global configuration/Server/Error reporting, the error message disappeared.
I hope the origin of this message will not be a problem later...

Problem hiding is not a solution(just my opinion)... problems need to try to resolve and that you do when you notify the manufacturer of Orao template?
All Kunena templates should work without errors if you set:
Global Configuration -- System -- Debug Settings -- Debug System -- Yes
Global Configuration -- Server -- Server Settings -- Error Reporting -- Maximum or Development

This is just my opinion...

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago #5 by Django29
I agree. That's why I said "I hope the origin of this message will not be a problem later... "

I sent the message to the template editor too.

Please Log in or Create an account to join the conversation.

More
5 years 11 months ago - 5 years 11 months ago #6 by sozzled

Django29 wrote: I sent the message to the template editor too.

Good luck.

According to the website where people can still obtain the Orao template for K 2.0], this template made its appearance 2 years ago and it has not been updated for K 3.0.

You may be right that the Orao template is more "suitable" for your wbesite but I think you should also accept the fact that the template is not compatible with K 3.0 . There are many other templates that are available (at relatively little cost) that may be more suitable and that are compatible with K 3.0.

In the meantime, you have a problem with the Orao template and our recommendation is that you should use a template that is compatible with K 3.0. It really comes down to the question of what is more important to you: your forum or your template ?
Last edit: 5 years 11 months ago by sozzled.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.113 seconds