Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Moderate Guests Not Working

More
10 years 2 months ago #1 by rgblogs
I am not sure this is bug or not, but something is not right.

I have enabled Public Posts in Forum. In category settings public access has rights to reply to posts.

In security settings, Moderate Guests setting is Yes.

Still, when people reply, posts are not moderated. They are published automatically.

I have no signature :)

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #2 by sozzled
Replied by sozzled on topic Moderate Guests Not Working
I am not claiming to know the answer - and if you are correct (in the sense that your forum is fairly typical) this would be a serious problem from a security perspective - but it may help us to know the context if you watch the video vimeo.com/69818669 .

I am also not claiming to be knowledgeable in this area because I never allow, under any circumstances, guests to post in any forum that I manage. I understand that there may be circumstances when people feel it's OK to allow guests to post but, I'm just saying, I don't have experience in such cases.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #3 by rgblogs
Replied by rgblogs on topic Moderate Guests Not Working
I installed Kunena Discuss as replacement of comments, so I do not want people to login or register to just leave a comment.

I have only one category where only replies are allowed by guests, not even creating new threads.

I have enabled Moderate Guests, but it is not working :(

Report Configuration


This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : **** | author: **** | version: **** | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.4 | creationdate: 2013-12-22

Kunena version detailed: Kunena 3.0.4 | 2013-12-22 [ Ukko ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: Content - Kunena Discuss 3.0.1

Modules: None


I have no signature :)

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #4 by sozzled
Replied by sozzled on topic Moderate Guests Not Working
This could be an Apache problem or it could be related to your Joomla site template but, because you have edited those parts of your configuration report, I can't be sure. If you edit your configuration report you're tying our hands as far as helping you.

I'm "flying blind in a snowstorm" because you edited your config. report.

You may (or may not) be aware of issues relating to guest posting with the Kunena Discuss module: see Kunena Discuss 3.0 Plugin does not allow guests to be the first to post article comments.

Apart from that, and because you edited your config. report (and because I have no experience otherwise in managing websites where guests may post on the forum) I have no other ideas to help you. Perhaps another member of the community, with more experience than me, can offer you some useful pointers.

Please Log in or Create an account to join the conversation.

More
10 years 1 month ago #5 by kai920
Replied by kai920 on topic Moderate Guests Not Working

rgblogs wrote: I am not sure this is bug or not, but something is not right.

I have enabled Public Posts in Forum. In category settings public access has rights to reply to posts.

In security settings, Moderate Guests setting is Yes.

Still, when people reply, posts are not moderated. They are published automatically.


I have the same issue, did you ever figure it out?

Guests can reply from within Kunena and replies require moderation (which is what I want), but when adding the comment through Joomla (using the Kunena Discuss plugin) the moderation is bypassed completely.

Please Log in or Create an account to join the conversation.

Time to create page: 0.568 seconds