×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question K 3.0.4: You do not have permissions to access this page for ALL topics

More
5 years 10 months ago #1 by jthrongard
I am seeing this message on all user levels for all topics. Categories open just fine but not topics. I'm using version 3.0.4 and did a search for this topic but only found to check category access levels (which I've done) and to update to latest version (which it is).

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 256M | Max file upload: 10M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : rt_corvus | author: RocketTheme, LLC | version: 1.1 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.4 | creationdate: 2013-12-22

Kunena version detailed: Kunena 3.0.4 | 2013-12-22 [ Ukko ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #2 by sozzled
(1) I do not know how you were able to install K 3.0.4 on J! 3.2.2 when you are using MySQL 5.0.96. How did you do this? You need MySQL 5.1.0 (or higher) to run J 3.2.2 and you need MySQL 5.1.0 (or higher) to use the Kunena installer. If you use MySQL 5.0.96 the K 3.0.4 installation procedure will fail.

(2) When I tried to look at your site, there is not much that I can see because of this message:



(3) When you eventually resolve the MySQL version problem, I recommend that you change your forum integration plugin settings as shown in red below:

Kunena - AlphaUserPoints Disabled
Kunena - Community Builder Disabled
Kunena - Gravatar Enabled: Disabled
Kunena - JomSocial Enabled: Disabled
Kunena - Joomla Enabled: access=1 login=1
Kunena - Kunena Enabled: avatar=1 profile=1
Kunena - UddeIM Enabled: Disabled

K 3.0.4 will not work without MySQL 5.1 (or higher) .
Attachments:

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #3 by jthrongard
I did ALL the above, including upgraded mysql and turning off the extra plugins. No change. Here's the new details:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 256M | Max file upload: 10M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : rt_corvus | author: RocketTheme, LLC | version: 1.1 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.4 | creationdate: 2013-12-22

Kunena version detailed: Kunena 3.0.4 | 2013-12-22 [ Ukko ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1


Also turned off maintenance mode so it can now be tested.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago - 5 years 10 months ago #4 by sozzled
You did not answer my original question about how you were able to install K 3.0.4 when you were running MySQL 5.0.96. It is my suspicion that K 3.0.4 was not properly installed. I suggest that you reinstall K 3.0.4 using the procedure recommended in K 3.0.4 Upgrade Guide ; it is my suspicion that the reason that you are having these problems is because of a faulty installation of K 3.0.4 on your website. I could be wrong but I think it's worth trying to reinstall K 3.0.4.

When I visited your website, as a guest/visitor, I was able to see topics posted on your forum. Under what conditions are you getting the message "You do not have permissions to access this page"?
Last edit: 5 years 10 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #5 by jthrongard
What I did was install it in Joomla 2.5 and then when we updated to 3.0 I just updated Kunena at that points as well. No error messages. Nothing. All seemed fine.

I just reinstalled Kunena and got no error messages.

You can see there are topics in each forum but go to a topic. You can see the error message under each topic. Specifically:
https://www.goodlookingloser.com/gll-joomla/forums?view=topic&catid=3&id=62899

I've tried it both as administrator and as guest. Same result.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #6 by sozzled

jthrongard wrote: What I did was install it in Joomla 2.5 and then when we updated to 3.0 I just updated Kunena at that points as well. No error messages. Nothing. All seemed fine.

Hmm ... puzzling!

As far as I know (and I could be very wrong) but, based on the fact that we've dealt before with " complaints " from people who have attempted to install K 3.0 on systems running MySQL 5.0.x, you should have received an error message during the installation process (unless you installed K 3.0.4 in some very peculiar, highly-customised way, that bypassed the version checking.

That's my understanding, anyway. As I said, based on the discussions I've had with the development team and coupled with the fact that, during the installation procedure, others have received the message

MySQL 5.0.96-community-log is not supported. Minimum required version is MySQL 5.1, but it is higly recommended to use MySQL 5.5 or later.


... I am surprised that you didn't get that message during your first attempted upgrade, even on J! 2.5 because it's the same installation procedure with the same version checking parts. :dry:

Getting back to the specific problem you are having, I see the point you are making.

Have you read about " how " to define permissions for your categories?

I still have my suspicions that the installation of K 3.0.4 is suspect and that re-installing it will address the problem. But ... I could be wrong on that score, too. :S

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #7 by jthrongard
Like I say I did reinstall 3.0.4 AFTER the upgrade to 5.5 and it didn't fix it.

Yes I've read the permissions and PUBLC is the main permission for each category. And as I understand it you wouldn't even be permitted to access the category (which you can do) if the permissions didn't allow it. It's only the TOPICS you can't access.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #8 by sozzled
Go to the Kunena Category Manager. Look at any of the categories where you cannot view the topics.

Look at the Permissions tab for that category.

What are the settings for the following items:

  1. Access Control Type
  2. Primary User Group
  3. Primary Includes Child Groups
  4. Secondary User Group
  5. Secondary Includes Child Groups

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago - 5 years 10 months ago #9 by jthrongard
1. - User Groups
2. Public
3. Yes
4. Public
5. Yes

The categories that DO work have 4 set as blank and have no other settings.

See screenshots.
Attachments:
Last edit: 5 years 10 months ago by jthrongard.

Please Log in or Create an account to join the conversation.

More
5 years 10 months ago #10 by rich
I think, you have a different problem. Your home page is corrupt. I can open all topics that are older than nine months.
Firebug shows this error on all pages. The error counter runs faster than a electric meter upwards.
TypeError: window.clipboardData is undefined
But I don't know what this means.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.326 seconds