×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved SOLVED: Edit existing posting: "You don't have permission to access /forum on this server."

More
4 years 10 months ago - 2 years 9 months ago #1 by Bastian
Hi,

I am receiving following error, when I try to edit an existing posting and press the save button.
Forbidden
You don't have permission to access /forum on this server.
I am Admin and I have authorization to this forum etc.
New postings isn't an issue.
What can I do?

Thanks in advance, Bastian

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 80M | Max file upload: 16M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : yoo_radiance | author: YOOtheme | version: 1.0.4 | creationdate: Unbekannt

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.3 | creationdate: 2013-10-20

Kunena version detailed: Kunena 3.0.3 | 2013-10-20 [ Bifrost ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.9.1

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1

Modules: Kunena Latest 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1

Last edit: 2 years 9 months ago by Bastian. Reason: topic solved with 4.0.8.

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago - 4 years 10 months ago #2 by rich
Hello Bastian,
You had this error about 1 year ago. Is it still the same? I see now that you were not repaired this menu item. It can be caused by this wrong menu item.
100022 Forumbeitrag schreiben usermenue view=topic&catid=0&layout=create mitglieder/aktiv-mitwirken/forumbeitrag-schreiben
Please change this menu item to "Menu Item Alias" and try again.

Attachments:
Last edit: 4 years 10 months ago by rich.

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago #3 by Bastian
Hello Rich,

you are right, still the same issue.
My workaround is editing the posting direct with phpmyadmin at the database. Not nice.

Coming back to your hint:
My Forum menu item is based Menu item Alias but I receive the error.
I changed now also the Menu 100022 to Menu item Alias.

Unfortuntely the same error message appears.

Cheers, Bastian

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago #4 by rich
Sorry about your wait, but I had to ask itself. Have you a directory named /forum on your installation? Then it gives this error. And if it so then rename the folder please.

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago #5 by Bastian
I can't find any folder "forum" with FTP program.

What's interessting, I am able to edit the second post of corresponding thread without any error message. Just at the first posting I am receiving the error message. Strange or isn't it?

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago - 4 years 10 months ago #6 by rich
Yes, it's very strange. The error "You don't have permission to access /forum on this server." comes from the server, not from Joomla or Kunena. Please try a test without Joomla SEO.
Last edit: 4 years 10 months ago by rich.

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago #7 by Bastian
Thanks for your Answer.

I did an additional test.
As the text of the first posting is quit long
 

I replaced the hole text with just one word: it works, no error message while updating.

It somehow dependends on the length of the text.
Does it makes sense?

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago #8 by rich
I think not it's the length of the text. If there's mod_security installed, it may do this, too if it detects "illegal" content. It basically blocks the request before it goes to php and renders error page that it is configured to do. Perhaps is it because?

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago - 4 years 10 months ago #9 by Bastian
No, there is no mod_security installed.

I did another test: when I create a new thread and the posting includes my previous text I receive also the error message. When I used instead another long text without any Boardcode it was possible without any problem.

So you assumption was right, it has something to do with the BC Code.
No clou if this is happend also with other KUNENA installations, may it's depending on core functionality?

Best regards, Bastian
Last edit: 4 years 10 months ago by Bastian.

Please Log in or Create an account to join the conversation.

More
4 years 10 months ago #10 by rich
You use any other security software or filter?
Is the text very secret or can you insert it here? Then I could test it. If you use the confidential tags, only moderators and you can see it.
[confidential]your text[/confidential]

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.196 seconds