×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question 500 Fatal Errors

More
4 years 5 months ago #1 by halewilson
500 Fatal Errors was created by halewilson
I'm getting the following fatal error message when trying to upload an image into a new post. My site is using Joomla v3.1.5 and Kunena v4.0.0

Fatal Error was detected!

The error was detected in the Libraries.

Fatal Error: Class 'KunenaCompatImage' not found in libraries/kunena/image/image.php on line 20

For support click here: Kunena Support

Go back

Can someone please help me?
Thank you kindly,
Halewilson

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #2 by halewilson
Replied by halewilson on topic 500 Fatal Errors
Here's my config report!

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : yoo_catalyst | author: YOOtheme | version: 1.0.7 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.0 | creationdate: 2015-05-31

Kunena version detailed: Kunena 4.0.0 | 2015-05-31 [ Sunset ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 3.0.1

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #3 by 810
Replied by 810 on topic 500 Fatal Errors
first try to update to K4.0.1

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #4 by 810
Replied by 810 on topic 500 Fatal Errors
also update joomla to J3.4.1

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #5 by halewilson
Replied by halewilson on topic 500 Fatal Errors
Thanks for the quick reply.

I am hesitant to upgrade my joomla 3.1.5 because my template has been heavily modified and I'm afraid I will have to rebuild my site all over again since my template is no longer supported by the developer and would require even more costly "tech support" subscriptions! Do you have a working version of Kunena Forums for Joomla 3.1.5?

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago - 4 years 5 months ago #6 by xillibit
Replied by xillibit on topic 500 Fatal Errors
Untill when you will keep this Joomla! version ? Do-you tried on test site with most recent Joomla! version if your template works ?

I can't test actually with the same Joomla! version that you are using because i have
issues with php 5.5.x and i haven't others php version installed, i will try to see if i found something to make working it

I have found a fix for it, under /libraries/kunena/compat create a directory joomla31. In joomla31 directory create two directories : image and layout

Copy files from /libraries/kunena/compat/joomla32/layout/ into /libraries/kunena/compat/joomla31/layout then in /libraries/kunena/compat/joomla31/image create a file nammed image.php, put in this file the following content:
<?php
/**
 * @package     Joomla.Platform
 * @subpackage  Image
 *
 * @copyright   Copyright (C) 2005 - 2013 Open Source Matters, Inc. All rights reserved.
 * @license     GNU General Public License version 2 or later; see LICENSE
 */
 
defined('JPATH_PLATFORM') or die;
 
/**
 * Compatibility layer for JImage
 */
class KunenaCompatImage extends JImage
{
        const SCALE_FIT = 6;
}

Then open the bootstrap.php in /libraries/kunena/ and at line 27 add the following thing :
elseif (version_compare(JVERSION, '3.1', '>') && version_compare(JVERSION, '3.2', '<'))
{
 
 JLoader::registerPrefix('KunenaCompat', KPATH_FRAMEWORK . '/compat/joomla31');
}

I don't provide support by PM, because this can be useful for someone else.
Last edit: 4 years 5 months ago by xillibit.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.125 seconds