×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved Cannot redeclare class KunenaTable in libraries/kunena/tables/kunena.php on line 13

More
5 years 6 months ago - 5 years 6 months ago #1 by AmazingB
500 Internal Server Error
Fatal Error was detected!
 
Fatal Error: Cannot redeclare class KunenaTable in libraries/kunena/tables/kunena.php on line 13
 
The error was detected in the Libraries.

This issue started when I migrated several websites from one server to another and affects ALL of my kunena builds. I get this error on pretty much any page that would access the mysql database. The rest of the site (joomla portion) works fine. The new server passes all php requirements and write permissions exist for all applicable files/folders. I'm guessing it may be a problem with the mysql database itself. I tried reinstalling kunena but that did not resolve the issue.

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 10M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : GoonDocks | author: P Enterprises | version: 1.0 | creationdate: Unknown

Kunena default template details : Garava - Kunena 2.x | author: www.TemplateKunena.com | version: 1.0.0 | creationdate: 15.12.2012

Kunena version detailed: Kunena 3.0.5 | 2014-03-09 [ Invecchiato ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.9.1 | UddeIM 3.2

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 5 years 6 months ago by AmazingB.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #2 by sozzled
Try a different Kunena template, the K 3.0 Blue Eagle one.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago - 5 years 6 months ago #3 by AmazingB

sozzled wrote: Try a different Kunena template, the K 3.0 Blue Eagle one.

Switched template to:
Blue Eagle - Default - Kunena Team - 3.0.5 - 2014-03-09

No change, kunena still will not load. It shouldn't be the template as I get this error in the back-end as well as the front-end - Anytime kunena attempts to access the mysql database.

Is there a way to check Kunena against the mysql database to ensure that all required fields exist? I know you can do this for other components such as Community Builder.
Last edit: 5 years 6 months ago by AmazingB.

Please Log in or Create an account to join the conversation.

More
5 years 6 months ago #4 by AmazingB
I just did an entire system update to the linux server, which included an apache update. After the update, the kunena forums seem to be working properly now.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.100 seconds