×
Blue Eagle (1.5.0) for K5.1 is released (20 Jul 2018)

Please update the Kunena Blue Eagle to 1.5.0 if you use Kunena 5.1.
We made several bug fixes and improvements. Also Blue Eagle has now all the features from Crypsis.
Download: www.kunena.org/download/templates/category/blue-eagle-5

× This category is for discussing issues with the K 3.0 Blue Eagle template.

As general background, My Joomla site template makes a mess of Kunena .

We do not answer questions about other templates for Kunena here.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question How can I change how [codes] are shown?

More
3 years 5 months ago #1 by findelat
Hello,

I am using Kunena 3.07 and Blue Eagle Template with some overrides included at our Joomla template.

But when we use [codes] these are shown with some strange colours.

I paste here an example:





So I would like to change them and I am not sure where to find it. I guess it should be here at the CSS, but colours does not match between these html color codes and those that are shown


#Kunena div.kmsgtext pre,
#Kunena div.kmsgtext code {
	border-left-color: #F4A94F;
	border-right-color: #222222;
	border-top-color: #222222;
	border-bottom-color: #222222;
	font-family: "Courier News", Courier, monospace;

BBCODE BUTTONS
-------------------------------------------------------------------- */
#Kunena img.kbbcode:hover {
	background-color: #e4e4e4;
}
#Kunena div#kbbcode-size-options span:hover {
	background-color: #e4e4e4;
}
#Kunena #kbbcode-toolbar li a:hover {
	background-color: #e4e4e4;
}
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator1,
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator2,
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator3,
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator4,
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator5,
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator6,
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator7,
#Kunena ul#kbbcode-toolbar li a#kbbcode-separator8 {
	background-color: #eeeeee;

Thank you in advanced
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #2 by findelat
I forgot to paste my configuration report

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : findelat | author: findelat | version: 1.0 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.7 | creationdate: 2015-02-01

Kunena version detailed: Kunena 3.0.7 | 2015-02-01 [ Galah ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIM 3.5

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | JomSocial - My Kunena Forum Menu 2.0.4 | JomSocial - My Kunena Forum Posts 2.0.4 | JomSocial - Kunena Groups 2.0.4

Modules: Kunena Latest 3.0.1 | Kunena Login 3.0.1

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #3 by 810
its loaded by:

www.riftmaniacos.net//plugins/system/jat...jatypo/typo/typo.css

so you need to add this on your template css:
pre, .code {
background-color: transparent !important;
}

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #4 by findelat
First of all, thank you.

I guess I miss something because it does not work :S

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #5 by 810
for me it looks good now
The following user(s) said Thank You: findelat

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #6 by findelat
Well, I have done some overrides at typo.css but still is a kind of messy, I think

This is the code I use at typo.css
pre,.code {
	background-color: #666 !important;
	border: 1px solid #F90 !important;
	border-left-width: 6px !important;
	font-family: Tahoma, Geneva, sans-serif !important;
	font-size:12px !important;
	font-style:normal !important;
	}

I would like to use only one font type, without italics with a clear background and dark types... where can I manage typography?

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #7 by 810
pre.php span {
font-style: normal !important;
}
The following user(s) said Thank You: findelat

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #8 by findelat
Well, this is the code I use:

pre,.code {
	background-color: #666 !important;
	border: 1px solid #F90 !important;
	border-left-width: 6px !important;
	font-family: Tahoma, Geneva, sans-serif !important;
	font-size: 12px !important;
	font-style: normal !important;
	font-color: #0C3 !important;
	}
pre.php span {
	font-style: normal !important;
}



But I see it like this





Url is shown in the same color than background :huh:

So I change background color... and some others codes disappear :S




I have chosen a strong color but I guess font-color: #0C3 is it not a valid order :(

pre,.code {
	background-color: #FBF5EF !important;
	border: 1px solid #F90 !important;
	border-left-width: 6px !important;
	font-family: Tahoma, Geneva, sans-serif !important;
	font-size: 12px !important;
	font-style: normal !important;
	font-color: #0C3 !important;
	}
pre.php span {
	font-style: normal !important;
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #9 by 810
font-color: #0C3 !important;

should be:
color: #0C3 !important;
The following user(s) said Thank You: findelat

Please Log in or Create an account to join the conversation.

More
3 years 5 months ago #10 by findelat
Thank you

So it remains like this





/* Pre, Code ---*/
pre,.code {
	background-color: #FBF5EF !important;
	border: 1px solid #F90 !important;
	border-left-width: 3px !important;
	border-bottom-left-radius: 3px !important;
	color: #454545 !important;
	font-family: Tahoma, Geneva, sans-serif !important;
	font-size: 12px !important;
	font-style: normal !important;
}
pre.php span {
	font-style: normal !important;
}
Attachments:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.592 seconds