×
Kunena 5.1.12.1 Released - Security release (22 Apr 2019)

The Kunena team has announce the arrival of Kunena 5.1.12.1 [K 5.1.12.1] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a security release.

Question Error message on Kunena login

More
8 years 2 months ago #1 by ashquadir
I have CB 1.3 and Kunena 1.6 installed. However, when somebody logs in through Kunena, the following message is received:

The profile page is not available for guests.


Why?




This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 20M

This message contains confidential information

Joomla default template details : PlanetHop_Template_1 | author: Ash Quadir | version: 1.0 | creationdate: 2011-02-28

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.6.3 | creationdate: 2011-01-31

Kunena version detailled: Installed version: 1.6.3 | Build: 4344 | Version name: Parlare | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.4) | Jomsocial: Installed (Version : 2.0.5) | UddeIm: Disabled or not installed

Third-party SEF components: sh404sef: Disabled or not installed | ARTIO JoomSEF: Disabled or not installed | AceSEF: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Enabled (Version : 1.6.0-RC1)

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #2 by sozzled

ashquadir wrote: The profile page is not available for guests. Why?

The reason is because this is how you have defined the access to Community Builder though your menu. If you want anyone to see CB profiles then you need to change the menu items that allow people to see user profiles. Does that help?

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #3 by ashquadir
Can you direct me how to do that?


I also recently received this message as well:

COM_KUNENA_ERROR_TOKEN

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #4 by sozzled

ashquadir wrote: Can you direct me how to do that?

This is a basic Joomla menu issue. If you cannot resolve this for yourself, for a modest fee I am sure someone can sort the issues out for you. Please remember, this is the Kunena support forum; our role here is not to answer questions about how to configure Community Builder or other Joomla extensions.

ashquadir wrote: I also recently received this message as well:

COM_KUNENA_ERROR_TOKEN

The actual text of the error message seems to suggest that you have an issue with your language settings.

I see, from looking at your website, that you are using a customised Kunena template (for example, there is no "powered by Kunena" footer on your site). Perhaps your problems are not caused by K 1.6.3 but are caused by the template that you are using. Do you get the same issues when you use the standard, unmodified, Blue Eagle (default) template? If you do not get those issues when you use a standard, unmodified, template then maybe you need to contact the developer of the Kunena template that you are using and report these problems to them.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #5 by ashquadir
I am using the Blue Eagle template. I just tweaked the colors of that template slightly.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #6 by sozzled

ashquadir wrote: I am using the Blue Eagle template. I just tweaked the colors of that template slightly.

... and you removed the "powered by Kunena" from the footer, too. Did you change anything else?

I can't tell, from the information you have given to us, whether there is something else in your Joomla site that is interfering with Kunena. Have you tested K 1.6.3 on a clean Joomla 1.5.22 website, with no other components, or add-ons, and do you still get these symptoms?

According to your K 1.6 configuration report, you are using the CB login function. If you are experiencing problems with login, perhaps you should try using the Joomla login module instead? :dry:

I also see that you have installed the My Kunena Forum Posts (Version : 1.6.0-RC1). This has no benefit in your situation. This module is used exclusively with JomSocial. You may be having these login problems because you have both JomSocial and Community Builder installed. This is very unusual and I think it's also asking for trouble. Because you have set Kunena to integrate user profiles with "auto detect" (and you have two different third-party user profiling components installed on your site) I think you need to change this "auto detect" value to one or the other system.

These things may or may not explain the current problems you're having with logging in, but I think there's a few things for you to think about.
The following user(s) said Thank You: ashquadir

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.123 seconds