×
Kunena 6.0.6 & Kunena 5.2.13 & blue eagle5 1.6.8 released as security release (28 Nov 2022)

The Kunena team has announce the arrival of Kunena 6.0.6 [K 6.0.6] which is now available for download as a native Joomla extension for J! 4.2.x. This is a security release.

Question Kunena 1.7.2 with Joomla 2.5.4 Performance Issues

More
10 years 6 months ago #1 by johntennock
I have migrated my Joomla 1.5 site to Joomla 2.5 using JUpgrade.

The first thing I notice is that in Joomla 2.5, Kunena takes much longer to load (approx 20 seconds) than in Joomla 1.5 (about 4 seconds).

Secondly, it frequently (but not always) returns a '500 Internal Server Error'

If I enable debug mode Kunena won't open at all, but returns the following error message.

500 - JDatabaseMySQLi::query: 1146 - Table 'transi25_jo151.j25_gj_jb' doesn't exist SQL=SELECT f.`category_id` FROM `j25_gj_jb` AS f LEFT JOIN `j25_gj_groups` AS g ON g.`id` = f.`group_id` LEFT JOIN `j25_gj_users` AS u ON u.`id_group` = g.`id` WHERE u.`id_user` = 0 AND u.`status` = 'active'


I would appreciate any pointers as to how I might overcome this.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago - 10 years 6 months ago #2 by sozzled
Your error is not coming from Kunena. it's coming from something that uses a table named j25_gj_users which is not used by Kunena.

As far as general performance issues are concerned, please read Improving Kunena performance in the Wiki.
Last edit: 10 years 6 months ago by sozzled.
The following user(s) said Thank You: johntennock

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #3 by johntennock
Thanks for that information. I'll work my way through it. However, I am still puzzled by the fact that the only change that caused the greatly increased loading time we the migration from J1.5 to J2.5. Anyway, I'll see what can be achieved by following the instructions in 'Improving Kunena Performance'.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #4 by Matias
gj = GroupJive, I think. It looks like some of the tables weren't migrated.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #5 by Matias
From CB team:

You have installed GroupJive 1.x, which is depreciated.

You need to upgrade to GJ 2.x or uninstall 1.x as 1.x doesn't work on J! 2.5

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #6 by johntennock
OK, with a bit more experimenting I have found that changing Search Engine Friendly URLs = No makes ALL the difference, but it's only an issue in the Joomla 2.5 migrated site. It's fine under Joomla 1.5.

Thanks for the feedback about GroupJive. We haven't been using it, in anticipation of upgrading to much superior GJ2 with J2.5. I'll uninstall GroupJive before doing the final migration.

Please Log in or Create an account to join the conversation.

More
10 years 6 months ago #7 by Matias
Which SEF component are you using? Joomla default?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.096 seconds