×
Kunena 5.2.3 released (Yesterday)

The Kunena team has announce the arrival of Kunena 5.2.3 [K 5.2.3] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.3

Question Users receive message "email not valid, please use valid email"

More
9 years 1 month ago #1 by hillbil35
Hello,
My users are telling me that when they type in a valid email into the email box to register as a new user, a caution box pops up telling them that the email is not valid. If they continue with the process and disregard the message, Kunena will send them an email verification saying they registered successfully. Why is this box popping up and how can I get rid of it?

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #2 by sozzled
Please read the posting guide printed at the top of this page. We may be able to answer your questions quicker if you provide the relevant information about your configuration. Thank you.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #3 by hillbil35
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 256M | Max file upload: 64M

This message contains confidential information

Joomla default template details : beez5 | author: Angie Radtke | version: 1.7.0 | creationdate: 21 May 2010

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.1 | creationdate: 2011-11-16

Kunena version detailled: Installed version: 1.7.1 | Build: 5162 | Version name: UnderUret | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: CommunityBuilder 1.7.1

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None




For more information, please see my website at www.prayerdove.com and go to Prayer Forum tab and try typing in an email and you will see what I mean.

Thanks.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #4 by CheechDogg
I checked out your registration and I see you are using Community Builder. This would have to be a setting in your community builder component.

Check all the settings for registration out.

File Attachment:
Find me on Facebook.

CAG Clan 1st and 3rd Person Shooter Clan on XBOX 360 & PS3

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #5 by sozzled

hillbil35 wrote: For more information, please see my website at www.prayerdove.com and go to Prayer Forum tab and try typing in an email and you will see what I mean.

I don't understand, "try typing in an email" ... where?

Your Kunena indicates that you have a custom Kunena menu. I suggest that you read How do I restore my Kunena menu? first. Next I would make sure that the forum email setting in the Forum Configuration matches the email setting in the Joomla Global Configuration to see if this resolved your problem.
Last edit: 9 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #6 by CheechDogg
I think he means entering an email in the registration form, which does give you warning.

File Attachment:
Find me on Facebook.

CAG Clan 1st and 3rd Person Shooter Clan on XBOX 360 & PS3

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #7 by sozzled
Ah, I see!

Community Builder allows the option of using either (or both a username or an email address when you login to the site. The Kunena login form uses whatever login integration is used. The config. report shows

Forum Configuration » Integration » Integration Options » Login and Registration = Auto Detect

This probably works. Alternatively, you can set

Forum Configuration » Integration » Integration Options » Login and Registration = Community Builder

In the CB configuration panel there is another setting to allow logging in with an email address:

CB Configuration Manager » General » Login field type = Username or email

I guess that if someone gets the message "email not valid, please use valid email" they're not using the right one. I don't know. Sounds like a CB question to me.
Last edit: 9 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #8 by CheechDogg
Yeah , I have a website I maintain that uses CB and I could not replicate this during registration. Weird...

File Attachment:
Find me on Facebook.

CAG Clan 1st and 3rd Person Shooter Clan on XBOX 360 & PS3

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #9 by sozzled
I don't think it's a registration issue. I think it's a login issue. I could be wrong.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #10 by hillbil35
Thanks for your help. I went into Kunena noticed the setting was already set to Auto Detect:

Forum Configuration » Integration » Integration Options » Login and Registration = Auto Detect

So I changed it to Community Builder:

Forum Configuration » Integration » Integration Options » Login and Registration = Community Builder

However, it still displays an error message. I went into Community Builder and changed the login field type to Username and email:

CB Configuration Manager » General » Login field type = Username or email

But that still doesn't work.

I went back into Kunena and changed the login and registration settings to reflect Joomla, and while I enjoy this login and registration much better, it erases my categories from Kunena which means my users will have no categories to create topics in.

Do you think I should just delete Community Builder from my Joomla and stick with Kunena only? I don't use community builder for anything on my website so maybe it is just confusing the backend by having it in there.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.184 seconds