Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

Question create account link missing in welcome box

More
11 years 2 months ago #1 by ajuking001
Hi,
I am a newbee and I apologize if this has been answered before, but I tried searching... honest!
I want to have the create account link in the welcome box. but in my fresh installation, i have 2 forgot links but no register link. I searched on these forums and i found many threads where users want to remove the register links or the forgot links. I on the contrary want it. Can you please tell me what went wrong in my installation?
Fresh J17 install. On it Fresh CB 1.7.1. On it fresh Kunena1.7
Selected CB everywhere in the Integrations tab.
I am attaching a screenshot.





This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 10M

This message contains confidential information

Joomla default template details : shaper_helix | author: JoomShaper.com | version: 1.1.0 | creationdate: Apr 2011

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailled: Installed version: 1.7.0 | Build: 5135 | Version name: Tale | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: CommunityBuilder 1.7.1

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Attachments:

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago - 11 years 2 months ago #2 by sozzled
Yes, this looks to be a real defect. I, too, looked to see if someone else has picked this up and, would you believe, in over 2 months that K 1.7.0 has been available, no one else seems to have raised this as a problem issue! :ohmy:

I have recently experienced exactly the same problem, too! At first I thought it was a problem with Community Builder integration - goodness knows, we've had enough of things involving login and registration there - and so I simply disabled the whole login/registration functionality from my forum. But that doesn't seem to be the case. Even if you select Forum Configuration » Integration » Integration Options » Login and Registration = Joomla, you won't even get a "registration" link, either!

So I don't think this is a Community Builder problem and I'm leaving this in the Support category for one of the development team to investigate and provide us with a response. Thanks for picking this up. What was everyone else doing? :whistle:
Last edit: 11 years 2 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #3 by sozzled
OK, we've found the cause. We just have to wait for the cure.

The cause is that CB recommends that you disable the Joomla "allow registrations" global setting and use CB's registration function instead. When Kunena creates the login/registration link, it honours the Joomla setting but it seems that Kunena disregards the CB setting. So, there's a bit of work that we need to do to fix this.
The following user(s) said Thank You: ajuking001

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #4 by ajuking001
Hi,
Many thanks for replying. You are absolutely right about the CB settings that ask us to disable registrations from joomla. I tinkered about a bit and came up with this immediately after I posted my request. so I thought I'd update this thread.

In the readme new install text file that comes with CB, this is what it says-

********11) If you want to allow registrations only through Community Builder
(recommended):
- in Admin->Components->Community Builder->Configuration->Registration:
set "Allow User Registration" to
"yes, independently of global site setting"
- in Admin->Site->Global Configuration->Site (Joomla 1.0/Mambo)
or Admin->Site->Global Configuration->System (Joomla 1.5/1.6/1.7):
set "Allow User Registration" to "No".
or on Joomla 1.6.0 Administration->Users->User Manager click the
Options button and set 'Allow User Registration' parameter to 'No'.*********

Heres what I did...
Test1- In K17, when I changed the Integrations TAB options to Kunena, the register link did not appear. But the URLs pointed to Joomla's forgot password.
Test2- In K17, put back the Integrations TAB options to CB, in J17 User Mgr. Options, turned On the parameter. And... woohoo, the create an account link was available in Kunena. It even showed the CB register link. The moment I turned it off, it was gone.
Thus, CB setting is to blame.

My question is if the User Mgr setting is kept On, will it interfere with CB's profile reg system? I can remove all the instances of login boxes and URls of Joomla. Will I need to sync users between CB and J17 often?

Regards,
Archie

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago #5 by sozzled

ajuking001 wrote: In K 1.7, [set the integration] to CB, in J17 User Mgr. Options, turned On the parameter. And... woohoo, the create an account link was available in Kunena.

I had no doubt in my mind that would work.

ajuking001 wrote: It even showed the CB register link.

That was going to be my next test, first thing in the morning. In your case you are using J! 1.7; in my case, my difficulty occurred when I was overhauling a J! 1.5 website and I still haven't verified whether CB 1.7 overrides Joomla's registration process irrespective of what you have the Joomla Global Configuration value set to. I suspect that it doesn't.

ajuking001 wrote: My question is if the User Mgr setting is kept On, will it interfere with CB's profile reg system? I can remove all the instances of login boxes and URls of Joomla. Will I need to sync users between CB and J17 often?

Those are very good questions and they should be asked at Joomlapolis . On the one hand it makes no sense for the CB installation procedure to make the recommendation while, on the other hand, CB's software ignores those recommendations. That's why I was fascinated by your response that the account create link pointed to CB (I still need to verify this is the case in J! 1.5).

Please Log in or Create an account to join the conversation.

More
11 years 2 months ago - 11 years 2 months ago #6 by sozzled
I'm still waiting for advice from the development team about how Kunena and Community Builder should interoperate together. On the one hand, I don't seem to have any problems if I ignore CB's recommendation about disallowing user registrations in Joomla Global Configuration (in J! 1.5) or User Manager settings (in J! 1.6 or J! 1.7). If you want to let users register via CB, then allow Joomla registration and use this:

CB Configuration Manager » Registration » Allow User Registration = yes, independently of global site setting

The only thing that I can't quite figure out is, if you use CB login/registration with Kunena, how to disable the "Remember Me" checkbox so that Kunena behaves the same way as CB login.

EDIT: Well, there is a downside to ignoring CB's recommendation: If a user tries to access a page on your site that they don't have access to, they're presented with the Joomla registration screen instead of the CB one. So, that's presents a security difficulty.
Last edit: 11 years 2 months ago by sozzled.

Please Log in or Create an account to join the conversation.

Time to create page: 0.295 seconds