×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Solved Installation fails at ~2% "Kunena Installation failed"

More
5 months 2 weeks ago #1 by Ascott80
I am trying to install Kunena 5.19 and 5.20 for the first time on a Joomla 3.9.22, PHP 7.3.10.

Installation stops after ~2% without a specific error message. It just says "Kunena Installation failed."
It generates an Kunena entry in "Components" but every time I click on any of the menu entries the installation tries to start again and fails.
3 tables are generated in the database. kunena system plugin is shown as active.

I am running DJ Classifieds on the same Joomla Installation and need a forum in addition. All other plugins, modules, extensiosn are working flawless.

What I did:

- Checked and confirmed PHP-settings and server requirements.
- I deactivated all non-Joomla plugins
- I tried installation via web, URL, Package-upload, unzipped it and tried via tmp, installed package also separately (I dropped the generated kunena-tables and uninstalled all kunana-plugins every time and cleared the cache before trying antoher method)

The fact that only 3 tables are generated looks to me like a mysql-problem?

Can anyone help me? Happy to provide a donation. I would love to work with Kunena.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #2 by Leen
Hello,

maybe the max_execution_ time or upload setting is too small
you could have a look at that at php.ini settings

minimal

but is already quite old so increasing the values to eg like this would be better
sample php.ini settings

L.v.d.A

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #3 by Ascott80
Thanks, checked all setting again and I even exceed some already. :(

BTW: Why does Kunena require allow_url_fopen: true?
Last edit: 5 months 1 week ago by Ascott80.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #4 by Leen
I don't know exactly why it should be on
but if a little googled then I come across in read more joomla itself that it is necessary
and if Kunena herself also says in explanation that he must, I assume that it is important.

L.v.d.A

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #5 by rich

The fact that only 3 tables are generated looks to me like a mysql-problem?

I'm not sure if it helps, but try the following:
First remove these 3 tables.
Then start the installation and when the installation stands, go to \administrator\components\com_kunena and remove the install.php
Then refresh in the backend the page.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #6 by Ascott80
If I do that the installation procedure stops (as the page is refreshed) and I of course get the error msg:

"42S02 SQLSTATE[42S02]: Base table or view not found: 1146 Table 'XXXXXXXXXXX_2.u4l80_kunena_configuration' doesn't exist ".

Because no table exists and the installation procedure has been stopped.

I cannot refresh without cancelling the installation process?
Last edit: 5 months 1 week ago by Ascott80.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #7 by rich

I cannot refresh without cancelling the installation process?

If you click on the browser refresh button, the installation should continue.
If does not work, maybe you can install Kunena, when already the database tables exists.
Have you a test page? I've created empty Kunena tables. Import this empty tables (adjust prefix) and try again to install Kunena.
But make no experiments on your live page without full backup please.
Attachments:
The following user(s) said Thank You: Ascott80

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #8 by Ascott80
Hi,
Thank you very much. I tried the following now:
- removing install.php + refreshing (no success, installation stops)
- removing all installed kunena-plugins, clearing the cache, dropping all *kunena*-tables in mysql.
- changed the table-name in your sql-file from "test_X" to "mytablename_X"
Now to see if this is a MySQL issue I did not try to reinstall Kunena but just tried to import the provided sql-file:
Now 2 interesting things are happening:
1. It only creates "mytablename_kunena_aliases" and "mytablename_kunena_announcements".
MySQL-Error-message:
"#1709 - Index column size too large. The maximum column size is 767 bytes."
So this seems to be a config-related issue on the webhoster-side.
Will keep you posted! thanks for the help so far!

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago - 5 months 1 week ago #9 by Ascott80
SUCCESS!
Adding "ROW_FORMAT=DYNAMIC" to the affected tables in the provided SQL-file did the trick.

Had to uninstall everything, imported the modified SQL, hit f5 during installation and TADA! :woohoo:

Thanks a lot!
Last edit: 5 months 1 week ago by Ascott80.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.095 seconds