×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Question Possible conflict with a Themler Template

More
2 years 2 months ago #1 by IanB
Hi,
I have just setup a rebuilt website with newly downloaded Joomla and extensions and a template designed from scratch in Themler. However, I am getting an error when trying to access the forums setup in Kunena. The page opens, but has a blank section of a screen plus before the content. With the debug tool set on I get the following message, but cannot resolve the issue.

Notice: Undefined variable: menutype in .../html/mod_menu/default_component.php on line 54

Rendering Error in layout Widget/Menu: Call to undefined function funcTagBuilder() in .../components/com_kunena/template/crypsisb3/layouts/widget/menu/default.php on line 121
Layout was rendered in .../libraries/kunena/layout/base.php on line 166


Please can someone suggest how I can correct this apparent conflict.

Many thanks, Ian.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago - 2 years 1 month ago #2 by Rokhi
I am having the same problem. Template layout flying to pieces etc. errors reported as you have experienced.

I installed the free K5 jf_simone template from joomla forest ( www.joomforest.com/kunena/templates ) and declared the variable $menutype in ...html/mod_menu/default_component.php. All those errors went away. Of course the menutype error will reappear when I update joomla so I should do an override.

I have not yet figured out what Joomla Forest are doing to integrate better with Themler, or why the variable $menutype is missing from the joomla core component but I think Kunena should probably investigate.
Last edit: 2 years 1 month ago by Rokhi. Reason: clarification

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #3 by billh210
What menu type can you share the code you used?

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago - 1 year 8 months ago #4 by 810
Please Update your wright framework.

github.com/joomlashack/wright/releases
Last edit: 1 year 8 months ago by 810.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.088 seconds